Notices
LS4 Performance Grand Prix GXP | Monte Carlo SS | Impala SS | LaCrosse Super

Rear drivers side thump

 
Old 03-23-2019, 07:12 PM
  #1  
Staging Lane
Thread Starter
 
NewYork Art's Avatar
 
Join Date: Dec 2006
Location: New York
Posts: 94
Default Rear drivers side thump

07 Monte SS original owner 107,000 miles.
Last spring a small thump,clunk,tap noise developed in the drivers rear. With 90+ miles I decided to do rear struts. Replaced the strut and mounts with OEM.
Noise still present, Then I replaced bushings for rear sway bar along with links. Then Both rear trailing arms, both sets of (control arms?) going side to side. and finally both wheel bearings. Yes while I was under there new rotors and brakes. THERE is nothing left to change. Still the noise.
I dropped the back seat while the wife drove the car around and I could feel the bumping on the strut top.
I don't see any rust on the metal. Tried retightening the strut top nut. I found a TBS to cut the rubber tabs from the coil spring. NO LUCK.
I wonder if the new strut could be bad? I recall it only took like 8-10lbs to push down or extract it.
Tomorrow I plan to tear it all apart hope to find something.
NewYork Art is offline  
Old 03-24-2019, 11:55 AM
  #2  
TECH Fanatic
iTrader: (4)
 
Join Date: Jul 2008
Location: Connecticut
Posts: 1,348
Default

Wow, thats frustrating, Doesn't sound like you missed anything. The GM braces tighten things up a bit, might help some and they can usually be found in a junkyard or are inexpensive new as well.Need the custom brackets for these cars too. Look around some, its a good investment anyway as they for sure work. Post back your findings, good luck!

https://montecarloforum.com/forum/fw...r-brace-27280/
rottonj is offline  
Old 03-27-2019, 07:48 AM
  #3  
Teching In
 
mcss_freak's Avatar
 
Join Date: Sep 2015
Location: Warrensburg,mo
Posts: 24
Default

Did you ever figured out what the problem was? I been having a similar issue on the right side going over small bumps. Iíll be changing out my springs/struts, mounts soon. Do you have lock collars on your sway bar (addco). Those collars hits the frame when the vehicle is compress, you must grind the down.
mcss_freak is offline  
 


Thread Tools
Search this Thread

About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: