Oil Pressure Drop at WOT - Page 3 - LS1TECH - Camaro and Firebird Forum Discussion

Notices
LT1-LT4 Modifications 1993-97 Gen II Small Block V8

Oil Pressure Drop at WOT

Old 09-15-2014, 08:06 AM
  #41  
TECH Regular
 
Jeff 97 Formula's Avatar
 
Join Date: May 2005
Posts: 443
Default

What are the symptoms of the pickup tube falling off? Trying to figure out if that happened to mine (although if it did, it happened years ago since I recently confirmed my oil pressure dropping briefly at WOT (which I never noticed until recently)).
Jeff 97 Formula is offline  
Old 09-15-2014, 08:56 AM
  #42  
TECH Veteran
iTrader: (12)
 
wrd1972's Avatar
 
Join Date: Mar 2006
Location: Central Kentucky
Posts: 4,607
Default

Originally Posted by Jeff 97 Formula View Post
What are the symptoms of the pickup tube falling off? Trying to figure out if that happened to mine (although if it did, it happened years ago since I recently confirmed my oil pressure dropping briefly at WOT (which I never noticed until recently)).
When the pickup tube falls off, the pressure will drop under hard braking and enough so that the engine light comes on. Its super easy to tell if the pickup has fallen off, smack the bottom of the oil pan with a mallet and if its off, you will hear it bounce.

Couple of years ago I unknowingly drove 200 miles to the tuner and made several dyno pulls all with the pickup off. Good thing the pan was full of oil. No damage done. Yikes.
wrd1972 is offline  
Old 09-15-2014, 08:09 PM
  #43  
TECH Regular
 
Jeff 97 Formula's Avatar
 
Join Date: May 2005
Posts: 443
Default

Maybe I'm starting to look too much into it.....but immediately after a cold start, PSI goes from 0 to around 55-60 at a fast idle (1200rpm), and the needle was "shaking" a few times for a period of 30 seconds (as if the PSI was going from 55-57 momentarily, about 3 times every 10 seconds. After 30-40 seconds as the engine is beginning to warm up, the oil pressure stabilizes.

Also today was a little cooler out. Still dropped but not as much. Another time I was kinda losing traction at WOT in 1st gear.....oil pressure did not drop at all.

Oil pressure does not drop any lower while braking (just drops as the engine RPM's go down).

Is the oil PSI at cold idle something I need to worry about (the shakiness of the needle)?
Jeff 97 Formula is offline  
Old 09-15-2014, 09:48 PM
  #44  
TECH Regular
Thread Starter
 
96LT1Z's Avatar
 
Join Date: May 2013
Location: Lincoln NE
Posts: 467
Default

Originally Posted by Jeff 97 Formula View Post
Maybe I'm starting to look too much into it.....but immediately after a cold start, PSI goes from 0 to around 55-60 at a fast idle (1200rpm), and the needle was "shaking" a few times for a period of 30 seconds (as if the PSI was going from 55-57 momentarily, about 3 times every 10 seconds. After 30-40 seconds as the engine is beginning to warm up, the oil pressure stabilizes.

Also today was a little cooler out. Still dropped but not as much. Another time I was kinda losing traction at WOT in 1st gear.....oil pressure did not drop at all.

Oil pressure does not drop any lower while braking (just drops as the engine RPM's go down).

Is the oil PSI at cold idle something I need to worry about (the shakiness of the needle)?
Unless its really freaking out bad, or you have severe pressure issues. I wouldn't worry about it. You seem to be stressing a lot about this. I was the same way. Save yourself the grief and just not worry about it so much. Keep tabs on it, but like it has been said several times in this thread. It is a common issue. So just drive your car man!
96LT1Z is offline  
Old 09-25-2014, 03:06 PM
  #45  
TECH Enthusiast
 
Join Date: Jun 2013
Location: Kernersville, NC
Posts: 657
Default

Originally Posted by Jeff 97 Formula View Post
My pan is stock, never taken off either so I should have everything that came from the factory still there.

I appreciate the solution...but that moroso pan you said won't clear the stock cats.
Keep in mind that I think the Canton pickup alone will help it. If I'm not mistaken the stock and Moroso pan depths are the same. The Canton pickup is much more centered in the pan than the stock pickup. The depth is automatically set by bolting the tab to the pump. Just something to think on and maybe try at some point.

I did get my Dad to braze the pickup to the pump all the way around(and still using the tab bolted to the pump), but that was just me over killing it.

I simply didn't feel good with the RPM's twisting up and seeing that pressure drop(revving to 6300 at the track). I had to find out what was causing it....and with much good advice did nail it.

Last edited by ACE1252; 09-25-2014 at 03:13 PM.
ACE1252 is offline  


Thread Tools
Search this Thread
Quick Reply: Oil Pressure Drop at WOT


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: