Misfire - LS1TECH - Camaro and Firebird Forum Discussion

Notices
LT1-LT4 Modifications 1993-97 Gen II Small Block V8

Misfire

Reply

Old 11-20-2017, 04:40 PM
  #1  
Launching!
Thread Starter
 
curacaoz28's Avatar
 
Join Date: Oct 2010
Posts: 244
Default Misfire

LT1 EXPERT HELP. for some weeks i felt like my car (94z28) was misfiring, i checked the sparkplug wires if they fire okk (with a sparkplug tester) and everything seems to be okk, i checked the injectors see if they click and they do (screwdriver on my ear)... so what i did is use a temp gun and 1 cylinder was a lot colder in comparison with the others, soo i removed the plug (see pic) the plug are there for about 5 weeks, i also notice the gap was very large on the plugs i thought these plug came gapped (TR55 IRIDIUM)
curacaoz28 is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
curacaoz28
Manual Transmission
4
09-22-2017 07:56 AM
curacaoz28
LT1-LT4 Modifications
5
09-12-2017 05:43 AM
curacaoz28
LT1-LT4 Modifications
14
08-31-2017 04:35 PM
papezl1camaro
New LS1 Owners - Newbie Tech
2
11-25-2016 12:13 AM
jetmech09
Generation III External Engine
6
10-18-2016 10:53 AM


Thread Tools
Search this Thread
Quick Reply: Misfire


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: