What tune for PCM and TAC to work - LS1TECH - Camaro and Firebird Forum Discussion

Notices
PCM Diagnostics & Tuning HP Tuners | Diablo | Pantera EFI
Sponsored by:
Sponsored by:

What tune for PCM and TAC to work

Old 12-26-2018, 08:50 PM
  #1  
TECH Enthusiast
Thread Starter
iTrader: (1)
 
Vetteman61's Avatar
 
Join Date: Oct 2010
Posts: 506
Default What tune for PCM and TAC to work

Hello,

All parts of my swap are from the same 2004 Avalanche (TAC/Pedal/Throttle Body/Etc) except for the PCM, which is a service code 12586243 from a 2004 Express Van. I had my tuner install a 2004 Tahoe on the PCM, however he said he may have put in a 2004 Avalanche. I have started the engine and cannot get the pedal to respond. I have checked the ohms for the pedal and I've checked the power and ground for the TAC and all are working.

Is there any reason an '04 Tahoe or '04 Avalanche tune would cause the TAC to not work with this setup? From what I understand installing the tune should allow the throttle components to work since they're all from the same vehicle and from what I've read so far the Express Van PCM, even though it came with DBC, is compatible with DRW. Is there anything else the tuner would need to do to make this work?

*Edit: I was able to get ahold of the tuner tonight and he confirmed it was a 2004 Avalanche tune he put on the 2004 Express van PCM.

Thanks,

Last edited by Vetteman61; 12-26-2018 at 09:15 PM.
Vetteman61 is online now  
Old 12-27-2018, 01:58 AM
  #2  
TECH Resident
iTrader: (5)
 
subeone's Avatar
 
Join Date: Apr 2013
Posts: 997
Default

2004 avvy file should run it no problem. That is, unless the ETC section doesnt have a "1" under system options for GMT800. If it has a 0, that is your problem. If not, wiring, tac, pedal or TB related.
subeone is offline  
Old 12-29-2018, 11:28 AM
  #3  
TECH Enthusiast
Thread Starter
iTrader: (1)
 
Vetteman61's Avatar
 
Join Date: Oct 2010
Posts: 506
Default

I believe what you mentioned here is what the problem was. Thought I can't remember exactly what the exact code was, it was that the GMT code had not been switched over to the truck rather than the Van. Thank you for the reply.
Vetteman61 is online now  


Thread Tools
Search this Thread

About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: