Transmission disaster - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Automatic Transmission
Log In 

Automatic Transmission
4L60E | 4L80E | TH350 | TH400 | TH2004R | Powerglide | Converters | Shift Kits
Sponsored by
PerformaBuilt Transmissions

Transmission disaster

Thread Tools Search this Thread
Old 04-07-2012, 10:59 AM   #1
Staging Lane
Trader Rating: 0
Join Date: Jun 2009
Posts: 60
Default Transmission disaster

I have an automatic transmission in my 1999 trans am. About a month ago I had it rebuilt due to it no longer shifting out of 1st gear. After the rebuild the transmission would shift but not under wide open throttle. I told the shop owner about this and he blamed the engine saying it needed a tune up. About a week later the transmission stopped shifting out of 1st gear again. The shop owner took it back and has been working on it for 2 weeks now (during that time he damaged my stereo, but thats another story). He says the transmission now shifts fine but won't lock up. He claims this is a problem with my cars computer and wants to install a new one. At this point I don't trust much anything this guy is telling me. Could the cars computer really be the problem?
Chief762x39 is offline   Reply With Quote
Old 04-07-2012, 11:57 AM   #2
TECH Senior Member
SparkyJJO's Avatar
Trader Rating: 10
Join Date: Aug 2007
Location: Ohio
Posts: 6,912
Send a message via AIM to SparkyJJO

Get a second opinion. That guy sounds way to ready to blame everything else.
'99 Camaro, Mystic Teal Metallic, cammed L36, A4 - a little faster than you may think
'02 Trailblazer LS, Forest Green Metallic, Vortec 4.2L I6, 4x4, lifted on 32s - the slow rusty winter beater
'07 Silverado LT Z71, Blue Granite Metallic, Vortec 5.3L, 4x4 - Cargo hauler, daily driver
SparkyJJO is offline   Reply With Quote

1st, gear, rebuild, trailblazer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -5. The time now is 10:52 AM.