Weird noises? - LS1TECH

Log In 


Florida Members Fun, sun and LS1's

Weird noises?

Reply
 
Thread Tools Search this Thread
Old 09-29-2008, 11:58 PM   #1
TECH Regular
Thread Starter
iTrader: (4)
 
The SSheriff's Avatar
 
Join Date: Oct 2006
Location: The Plywood State
Posts: 492
Default Weird noises?

Hello everyone,

I just wanted some input on some noises that have been coming from my 99 SS.

1. At idle and at 3000+RPM, I can hear and feel a "clacking" through the shifter. It sounds like a little choo-choo train. The shifter I have is a Lous Short Stick.

2. Whenever I turn my steering wheel, I can hear a sound that kind of resembles nails dragging across a cloth seat. I wouldn't describe it as a whirring though.

3. Whenever I am at 5000+RPM and engaged at full throttle, I can hear the sound that resembles the tearing or shredding of paper.

Any suggestions as to what problems these are?
The SSheriff is offline   Reply With Quote
Old 09-30-2008, 04:08 AM   #2
TECH Enthusiast
iTrader: (1)
 
KameleonTransAm's Avatar
 
Join Date: Jul 2006
Location: JAX, FL
Posts: 601
Default

No suggestions, but all of those do indeed scare me. Good luck!
KameleonTransAm is offline   Reply With Quote
Old 09-30-2008, 05:18 PM   #3
10 & 11 Second Club
iTrader: (2)
 
Caveman's Avatar
 
Join Date: Nov 2002
Location: Orlando Fl.
Posts: 2,584
Default

Sounds like evil spirits to me .
Caveman is offline   Reply With Quote
Old 09-30-2008, 07:34 PM   #4
TECH Apprentice
iTrader: (4)
 
R1ch's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 324
Default

Sounds like your basic 9 year old Gm.
R1ch is offline   Reply With Quote
Old 09-30-2008, 08:02 PM   #5
On The Tree
 
bobodog's Avatar
 
Join Date: Dec 2005
Location: ALACHUA, FL
Posts: 152
Default

all i know is when my car starts making funny noises i beat the hell out of it so it either breaks or goes away. either way i get piece of mind.if you dont its gonna worry you to death. most of the time the noise goes away. no worries. if it aint ticking,rattling or whining i start to worry.
bobodog is offline   Reply With Quote
Old 09-30-2008, 09:10 PM   #6
On The Tree
iTrader: (5)
 
theguyulove2hate's Avatar
 
Join Date: Oct 2007
Location: Lake Worth, FL
Posts: 174
Default

number 2 sounds like it is your i-shaft
theguyulove2hate is offline   Reply With Quote
Old 10-01-2008, 02:23 AM   #7
10 Second Club
iTrader: (2)
 
ALLMOTOR346CI's Avatar
 
Join Date: Jul 2007
Location: kissimmee FL.
Posts: 349
Default

Have no idea but hopefully it's nothing to bad goodluck tho!
ALLMOTOR346CI is offline   Reply With Quote
Old 10-02-2008, 09:49 PM   #8
12 Second Club
iTrader: (22)
 
92slowmaro's Avatar
 
Join Date: Nov 2005
Location: above you
Posts: 546
Default

hyprocondriac
92slowmaro is offline   Reply With Quote
Old 10-03-2008, 01:04 PM   #9
TECH Regular
Thread Starter
iTrader: (4)
 
The SSheriff's Avatar
 
Join Date: Oct 2006
Location: The Plywood State
Posts: 492
Default

Well, let me ask this..... what does detonation sound like? I think my knock sensor may be on its way out.
The SSheriff is offline   Reply With Quote
Old 10-03-2008, 05:21 PM   #10
12 Second Club
iTrader: (22)
 
92slowmaro's Avatar
 
Join Date: Nov 2005
Location: above you
Posts: 546
Default

like shaking a can of marbles... if it doesnt have a code for the knock sensors dont worry about it.
92slowmaro is offline   Reply With Quote
Old 10-03-2008, 09:32 PM   #11
TECH Junkie
iTrader: (9)
 
bboyferal's Avatar
 
Join Date: Apr 2005
Location: Miami, FL
Posts: 3,472
Default

#1 Tranny mount.

#2 Possible PS pump or rack problem... Fluid is fine?

#3 I don't know, but my red TA did the same for a few months when the car was stock... I turbocharged it and, lo and behold, it ceased.
bboyferal is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Trying to find my friends old truck in NC TurboSam Southern Members 0 06-21-2015 10:07 PM
motor choices jesus lq9 Generation III Internal Engine 5 06-07-2015 01:29 PM
Knocking fbdy4life Generation III Internal Engine 0 09-23-2014 10:43 PM
83 camino Swoop Dogg Racer's Lounge 5 06-18-2014 12:35 PM
high RPM rattle Nando92 New LS1 Owners - Newbie Tech 1 05-14-2011 10:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:35 PM.