View Full Version : Tick sound. coming from right side of engine


GXPPOWER
05-17-2007, 03:54 PM
its not the piston slap or anything. it almost sounds like an exhaust leak but im not sure. i used a stethascope or whatever and its distincly heard on the right side headers area. on the left side its Very Faint.

what could cause some of these ticking sounds. also if you lay down next to the car the ticking sound is easily heard which makes me even more belive its an exhaust leak. but just giving the chance for anyone else to chime in if their could be more possibilities.

i have pacesetter long tube headers with thw TSP true dual exhaust.

blackbirdls1
05-17-2007, 04:03 PM
my car makes ticking but it goes away, I thought i had an exhaust leak also but after driving around it goes away i think its just piston slap making noise through my headers or something

tennz28
05-17-2007, 04:05 PM
Do your Pacesetters have the AIR tubes on them? If so check them with the car running put your hand on the sides of where the tube meets the header if you feel air hitting your hand change the gasket. GM gaskets for AIR are like 5 bucks for 2. Other than that look on your block where the header flange is, if theres a leak there will be some black stain marks on the head from where its leaking.

GXPPOWER
06-10-2007, 05:45 PM
not sure what you mean by air tubes on the headers? only have 2 holes where the front 02 sensors are. other than that their is no other openings other than ofcourse where the headers go into the engines itself.

its not piston slap because i know the piston slap sound i already had that very faint . this is louder tick. sound. i re-used the GM gaskets that were on the manfolds and they were in good shape. im wondering if over time the muffers tips every so often hitting something if maybe they have bent the headers seal some?

2_wacko
06-11-2007, 10:39 PM
I had a ticking noise coming from the engine, tuned out to be a loose spark plug, and one loose wire. No more tick.

nostyta
06-12-2007, 06:34 AM
I had a ticking noise coming from the engine, turned out to be a loose spark plug, and one loose wire. No more tick.
I had about the same problem, just that I had two loose plugs. :bang:

2002_Z28_Six_Speed
06-12-2007, 01:10 PM
No comment on loose plugs. Put your steth on each injector. Maybe one is bad.

Rob@EFIAlchemy
06-12-2007, 01:17 PM
i have the same noise been trying to figure it out for about a year now still drives strong so i dont worry as much

tylerdj
06-12-2007, 04:39 PM
Might try to re-tighten your header bolts...sometimes they'll back out enough to get a small exhaust leak. I would also make sure all of your spark plug wires are on good.