What is the problem? - LS1TECH - Camaro and Firebird Forum Discussion



Dynamometer Results & Comparisons Dyno Records | Dyno Discussion | Dyno Wars

What is the problem?

Reply
 
Thread Tools Search this Thread
Old 04-11-2009, 10:36 PM   #1
Teching In
Thread Starter
 
ttsscamaro1's Avatar
 
Join Date: Apr 2008
Location: burleson texas
Posts: 13
Default What is the problem?

I got this camaro from a shop that is not open anymore and started with a big piece.Well now it is come a long way but this thing has Z06 heads and was told that it had a cam for a turbo it has a big lope to it.Took it to speed tech great shop to get it tuned on the dyno and make 330hp what is up with that it seens to run ok but what is up with that?Have headers as well with true dauls.What do you guys think
ttsscamaro1 is offline   Reply With Quote
Old 04-11-2009, 11:17 PM   #2
TECH Fanatic
iTrader: (71)
 
MrElectric03's Avatar
 
Join Date: Dec 2007
Location: Southern California
Posts: 1,884
Default

First off what year is it? Is it Manual or Auto? Does it have stock or taller gears?Stock or aftermarket rear?

Sonce you have Z06 heads they have 243 cast in the head right? How much of a lope does the cam have?

It does seem low but without knowing exact specs on the cam and the car its hard to say how low.
MrElectric03 is offline   Reply With Quote
Old 04-12-2009, 01:12 AM   #3
Teching In
Thread Starter
 
ttsscamaro1's Avatar
 
Join Date: Apr 2008
Location: burleson texas
Posts: 13
Default sorry

m6,373 rear,2000,yes z06 heads dont know cam specs but it lopes hard

Last edited by ttsscamaro1; 04-12-2009 at 01:17 AM.
ttsscamaro1 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Seattle area alignment shop cscott1 Northwest Members 4 07-27-2017 01:34 PM
yet another cam bearing question (after machine shop) and oil pump mjl1977 Generation III Internal Engine 15 07-22-2016 11:10 AM
Tune for a big cam on stock motor fonzie85 PCM Diagnostics & Tuning 2 05-27-2016 12:28 PM
LY6 Motor, bought used TH400 but found metal inside TC, rebuild or...?? BigTom209 Automatic Transmission 4 04-12-2016 01:12 AM
Wanted:So Cal Shop's That do LS1 Swaps? NOVA Western Members 14 09-15-2005 12:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 08:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: