Notices
Forced Induction Superchargers | Turbochargers | Intercoolers

Overboosting problem..

 
Old 05-19-2019, 12:14 AM
  #1  
Teching In
Thread Starter
 
Join Date: Feb 2015
Posts: 47
Likes: 0
Received 0 Likes on 0 Posts
Question Overboosting problem..

I am having a strange problem with over boosting on my new turbo setup. The engine is a 5.3 with a sloppy stage 2 cam and a GT45 turbo with 44mm wastegate, 3.5" downpipe.
On my first dyno session I was hitting around 12 PSI at 3800-4000 RPM and I only wanted to run max around 8 PSI.
So I took it home and installed a lighter spring. Next session I was still getting up to 14 PSI at 5200RPM, so just out of curiosity I removed the spring completely and I still got to 10 PSI at 5800 RPM which doesn't seem right at all.

I ran this turbo/wastegate combo before, but with a different header/crossover setup and didn't have issues.

Is it just a wastegate location problem? It seems to move smoothly by hand. Would it work better if I welded it to the turbine housing?
Any advise would be appreciated.







Dave3891 is offline  
Old 05-19-2019, 01:45 AM
  #2  
TECH Fanatic
iTrader: (1)
 
Join Date: Aug 2014
Posts: 1,599
Likes: 0
Received 0 Likes on 0 Posts
Default

Priority isnít ideal IMO. Is there a reference line to the bottom of the gate? Looks like the hose is cut off just before the clamp. If so, put a line on it from the compressor housing.
3 window is offline  
Old 05-19-2019, 10:22 AM
  #3  
Teching In
Thread Starter
 
Join Date: Feb 2015
Posts: 47
Likes: 0
Received 0 Likes on 0 Posts
Default

Reference is hooked up, picture was just a old one from mock up. Here is a current one



Dave3891 is offline  
Old 05-19-2019, 11:49 AM
  #4  
TECH Fanatic
iTrader: (1)
 
Join Date: Aug 2014
Posts: 1,599
Likes: 0
Received 0 Likes on 0 Posts
Default

Explain how your reference line is hooked up. Looks like itís going to a solenoid.
3 window is offline  
Old 05-19-2019, 11:58 AM
  #5  
Teching In
Thread Starter
 
Join Date: Feb 2015
Posts: 47
Likes: 0
Received 0 Likes on 0 Posts
Default

Dave3891 is offline  
Old 05-19-2019, 02:14 PM
  #6  
TECH Fanatic
iTrader: (1)
 
Join Date: Aug 2014
Posts: 1,599
Likes: 0
Received 0 Likes on 0 Posts
Default

So no spring in the gate and a reference line to the bottom (not the dome) and you still made 10 psi? Put a rag in the pipe off the gate and make sure the gateís opening. If it is, move it. If itís not replace it.
3 window is offline  
Old 05-20-2019, 11:05 AM
  #7  
TECH Fanatic
iTrader: (1)
 
Kfxguy's Avatar
 
Join Date: Apr 2017
Posts: 1,643
Likes: 0
Received 1 Like on 1 Post
Default

For anyone else reading this. For a cheap overboost protection, pick your max boost and about 1 psi above that, add a bunch of fuel. It has saved my motor a few times doing this. Youll feel it nose over and lose power. Its up to you now to let off.
Kfxguy is online now  
 


Thread Tools
Search this Thread

About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: