Help me out, replaced steering wheel, now the horn buttons don't work. - LS1TECH - Camaro and Firebird Forum Discussion



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

Help me out, replaced steering wheel, now the horn buttons don't work.

Reply
 
Thread Tools Search this Thread
Old 02-27-2017, 11:15 AM   #1
UNDER PRESSURE MOD
Thread Starter
iTrader: (19)
 
The Alchemist's Avatar
 
Join Date: Nov 2001
Location: Doylestown PA
Posts: 10,781
Default Help me out, replaced steering wheel, now the horn buttons don't work.

Ok, so over the weekend, I replaced my steering wheel with another factory wheel. Now the horn buttons don't work.

When I lock/unlock the car the horn works, so it's not a horn problem. It has to be the steering wheel buttons.

So my next step is to remove the airbag, and change over the contacts from the original wheel to see if that fixes it.

Are there any diagrams of how the the horn buttons work? I'm not the greatest when it comes to electrical.
The Alchemist is offline   Reply With Quote
Old 02-27-2017, 11:45 AM   #2
TECH Enthusiast
 
Join Date: Apr 2011
Posts: 505
Default

http://www.corvetteforum.com/forums/...stion-wire.jpg

That thing goes in this thing (cam cancel)

http://www.steeringcolumnservices.co...ges/horn02.jpg

and when you press your horn button down, it makes contact thus producing a horn sound.


I'll upload the service manual page in a bit.

Oops, can't upload. Sorry. Try page 2-62 in the 2000 service manual.

Last edited by ShovelMan; 02-27-2017 at 12:00 PM. Reason: exceeds 5MB
ShovelMan is offline   Reply With Quote
Old 02-27-2017, 02:35 PM   #3
UNDER PRESSURE MOD
Thread Starter
iTrader: (19)
 
The Alchemist's Avatar
 
Join Date: Nov 2001
Location: Doylestown PA
Posts: 10,781
Default

Ok. Let me try to replace the contacts and see if that fixes it.
The Alchemist is offline   Reply With Quote
Old 02-27-2017, 04:19 PM   #4
UNDER PRESSURE MOD
Thread Starter
iTrader: (19)
 
The Alchemist's Avatar
 
Join Date: Nov 2001
Location: Doylestown PA
Posts: 10,781
Default

I figured it out. It was a combination of issues. When they finished the wheel, they had sprayed it with a clear, and it coated the contacts, and then the spring retainer thing wasn't being held in contact either.

Thanks for the help guys.
The Alchemist is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wiring in universal low tone horn? JT2000WS6 General Maintenance & Repairs 3 09-20-2017 10:48 AM
TPMS relearn procedure doesn't work isis Cadillac CTS-V 2004-2007 (Gen I) 9 04-07-2017 05:23 PM
Two new electrical problems CTSvOH Cadillac CTS-V 2004-2007 (Gen I) 16 03-10-2017 08:10 PM
02 Camaro Horn power issues Rodney Mccullough Chevrolet Camaro 1967-2002 5 02-22-2017 10:01 PM
Train/Air Horns for People Sitting at Red Lights and Texting... Mr. Sandog General LSX Automobile Discussion 6 10-19-2016 09:36 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: