Re-installing ATI balancer - LS1TECH - Camaro and Firebird Forum Discussion

Notices
Generation III External Engine LS1 | LS6 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories
Sponsored by:
Sponsored by:

Re-installing ATI balancer

Old 11-08-2018, 10:17 AM
  #1  
Staging Lane
Thread Starter
iTrader: (1)
 
00blownWS6's Avatar
 
Join Date: May 2006
Location: Jersey
Posts: 75
Default Re-installing ATI balancer

Iím pulling the balancer off to change a front crank seal thatís leaking. Couple of questions while doing this process. When I remove the 8 rib pulley for the procharger, do I use those 3 bolt holes to mount the puller tool on? Also, when I go to re-install the balancer, any tips on how to re-align the hole for the crank pin? I already pinned it from the front with the procharger crank pin kit. The pin is only about an inch long and does not go the full length of the balancer hub. Thanks in advance!
00blownWS6 is offline  
Old 11-08-2018, 10:40 AM
  #2  
TECH Senior Member
iTrader: (26)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 7,798
Default

I just took mine off last week. We took the blower pulley off as well as the balancer and took off the AC pulley bolts and pushed the AC pulley towards the motor so the puller could grab the back of the ATI hub itself. I went back to a factory balancer so no tips there.
ddnspider is offline  
Old 11-08-2018, 11:14 AM
  #3  
Staging Lane
Thread Starter
iTrader: (1)
 
00blownWS6's Avatar
 
Join Date: May 2006
Location: Jersey
Posts: 75
Default

I was planing on pulling the AC pulley off with the hub. Why did you go back to the stock balancer just out of curiousity?
00blownWS6 is offline  
Old 11-08-2018, 11:15 AM
  #4  
TECH Senior Member
iTrader: (26)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 7,798
Default

No mo blower...
ddnspider is offline  
Old 11-09-2018, 03:41 AM
  #5  
Launching!
iTrader: (5)
 
Join Date: Apr 2015
Location: Iowa
Posts: 255
Default

Originally Posted by 00blownWS6 View Post
Iím pulling the balancer off to change a front crank seal thatís leaking. Couple of questions while doing this process. When I remove the 8 rib pulley for the procharger, do I use those 3 bolt holes to mount the puller tool on? Also, when I go to re-install the balancer, any tips on how to re-align the hole for the crank pin? I already pinned it from the front with the procharger crank pin kit. The pin is only about an inch long and does not go the full length of the balancer hub. Thanks in advance!

I did this when we did the cam install. We realigned the pin by eyeballing it and getting close. I had radiator out so i sat in front of motor on ground and eyeballed close. It was very close so we were able to get it back on. This took about 4 attempts before it was good enough we could get pin back in. I was informed that we could have drilled a new hole 180 apart from original one if needed.

As for removing it we only removed the blower pulley and left the AC one attached. I used the ATI tool so not sure if that made a difference or not.
klinznilk is offline  


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: