Harmonic Balancer replaced twice in a year. Worry? - LS1TECH - Camaro and Firebird Forum Discussion

Notices
Generation IV External Engine LS2 | LS3 | LS7 | L92 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories
Sponsored by:
Sponsored by:

Harmonic Balancer replaced twice in a year. Worry?

Reply

Old 12-15-2017, 02:27 AM
  #1  
Teching In
Thread Starter
 
RoadWarrior93's Avatar
 
Join Date: Jan 2017
Location: Everett,WA
Posts: 26
Default Harmonic Balancer replaced twice in a year. Worry?

I have a 2007 Cadillac CTS-V (LS2) that I've almost had for a year now

Bought from a Chevy dealer and did pay for a third party warranty because it's my only car and did not know a whole lot about wrenching at the time. Early on I experienced a squeaking noise on cold starts because I bought in the winter it was pronounced. Would go away after 5 minutes of driving and would have to be dead cold to start again. The Dealership said it was the harmonic balancer so my warranty paid for the repair but I had to pay for the new belts in May. Now that winter came along the squeak was back! And seemed worse than before. I turned it in and they said it was the balancer again. The positive thing was the part had a GM warranty so it was $0 cost this time. However they took 2 days to work on it and said GM's part warranty doesn't provide a loaner car which was extremely inconvenient, but it did solve the issue and it's dead silent on 30 degree mornings. Anyway my main concern was if there might be something more concerning possibly going on? What would happen if I just let this inconvenient squeak continue?
RoadWarrior93 is offline  
Reply With Quote
Old 12-19-2017, 07:40 AM
  #2  
TECH Fanatic
iTrader: (14)
 
farmington's Avatar
 
Join Date: Jun 2010
Location: Metro Detroit area
Posts: 1,742
Default

Seems to me I heard of balancer problems on Corvettes of that era. They started to visibly wobble. Most people were replacing them with aftermarket balancers as even the factory replacements went bad.
farmington is offline  
Reply With Quote
Old 12-19-2017, 10:23 PM
  #3  
Teching In
 
Join Date: Mar 2017
Posts: 16
Default

Piggy backing off of what farmington said I found out about balancer issues on Vettes from that time frame when I was researching balancers myself for my truck but I'm sure the issues were happening to CTS-V's as well;


Like farmington said a few switched to a ATI or IW balancer to "solve" the problem.
Mordis is offline  
Reply With Quote
Old 12-20-2017, 08:31 AM
  #4  
TECH Fanatic
iTrader: (14)
 
farmington's Avatar
 
Join Date: Jun 2010
Location: Metro Detroit area
Posts: 1,742
Default

or Powerbond balancers
farmington is offline  
Reply With Quote
Old 01-13-2018, 11:14 AM
  #5  
TECH Fanatic
iTrader: (11)
 
flintwrench69's Avatar
 
Join Date: May 2008
Location: Mt Morris, Michigan
Posts: 1,947
Default

Originally Posted by farmington View Post
or Powerbond balancers
I did one on an 05 LS2 vette 60k miles. Stocker was wobbling bad. Believe it was a Powerbond pulley I replaced it with, $75 at Oreillys & looked factory. Still running my stock original LS1 pulley on 6.2 motor I built
flintwrench69 is offline  
Reply With Quote
Old 01-13-2018, 12:27 PM
  #6  
TECH Resident
iTrader: (31)
 
5.7stroker's Avatar
 
Join Date: Apr 2009
Location: OH
Posts: 889
Default

If it's not ATI, it doesn't go on my car.
5.7stroker is offline  
Reply With Quote
Old 01-13-2018, 01:19 PM
  #7  
TECH Junkie
iTrader: (3)
 
BudRacing's Avatar
 
Join Date: Dec 2006
Location: Dunwoody, GA
Posts: 3,487
Default

I wouldn't hesitate to put a Fluidampr on my car. I just happened to catch a deal on a blem ATI on Ebay for $250. For some reason I don't think the LS6 variants had the issue. Mine had 170k on it when replaced and it wasn't bad. I was just chasing vibration issues which it didn't solve.
BudRacing is offline  
Reply With Quote
Old 01-14-2018, 10:39 AM
  #8  
10 Second Club
iTrader: (4)
 
Darth_V8r's Avatar
 
Join Date: Jul 2014
Location: My own internal universe
Posts: 6,038
Default

Originally Posted by 5.7stroker
If it's not ATI, it doesn't go on my car.
Originally Posted by BudRacing
I wouldn't hesitate to put a Fluidampr on my car. I just happened to catch a deal on a blem ATI on Ebay for $250. For some reason I don't think the LS6 variants had the issue. Mine had 170k on it when replaced and it wasn't bad. I was just chasing vibration issues which it didn't solve.
I've got a few friends who chased the dampener causing false knock, etc. ATI fixed it in all cases. That was on LS6, LS2, and LS3
Darth_V8r is offline  
Reply With Quote
Old 01-16-2018, 10:03 AM
  #9  
TECH Apprentice
 
KILLERARMY's Avatar
 
Join Date: Mar 2005
Location: Raleigh,NC
Posts: 350
Default

Innovator West Pulley is also a choice.
KILLERARMY is offline  
Reply With Quote
Old 01-21-2018, 11:28 AM
  #10  
TECH Enthusiast
 
Join Date: Apr 2010
Location: Central Texas
Posts: 697
Default

I had a SLP under drive that caused my engine to "see" knock and pull timing!! Chased it along time and spent lotsa money before I figured it out..
cookseyb is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jmilz28
Cadillac CTS-V 2004-2007 (Gen I)
19
05-02-2017 06:17 AM
user_ls1
General Maintenance & Repairs
9
03-14-2017 09:28 AM
crash41301
Generation IV Internal Engine
5
08-14-2016 08:39 AM
Kmaroman
Generation III External Engine
0
03-11-2016 11:39 PM


Thread Tools
Search this Thread
Quick Reply: Harmonic Balancer replaced twice in a year. Worry?


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: