Reuse pistons? - Page 2 - LS1TECH - Camaro and Firebird Forum Discussion

Notices
Generation IV Internal Engine 2005-2014 LS2 | LS3 | LS7 | L92 | LS9

Reuse pistons?

Old 12-16-2018, 09:41 AM
  #21  
Teching In
Thread Starter
 
WoodstockSparky's Avatar
 
Join Date: Mar 2018
Posts: 12
Default Well I found the problem

Oh boy nothing like a $500 motor.
Found this:

and what the hell is this? was in the oil pan, part of the oil sump?

WoodstockSparky is offline  
Old 12-18-2018, 08:52 PM
  #22  
Teching In
Thread Starter
 
WoodstockSparky's Avatar
 
Join Date: Mar 2018
Posts: 12
Default

Hey mods how about some help?
My update and pictures are lost in the world of waiting to be posted........
WoodstockSparky is offline  
Old 12-19-2018, 09:10 AM
  #23  
Teching In
Thread Starter
 
WoodstockSparky's Avatar
 
Join Date: Mar 2018
Posts: 12
Default Mods

Any mods available to update this thread?
Originally Posted by WoodstockSparky View Post
Hey mods how about some help?
My update and pictures are lost in the world of waiting to be posted........
WoodstockSparky is offline  
Old 12-19-2018, 08:03 PM
  #24  
Launching!
iTrader: (2)
 
Join Date: Apr 2012
Location: SF Bay Area
Posts: 230
Default

Looks like the timing chain tensioner failed and parts fell in the oil pan. Can you confirm the cam and crank gears are still aligned correctly? If the chain jumped a few teeth that may have caused the valve interference
s30.hybrid is offline  


Thread Tools
Search this Thread

About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: