LS3 possible balance issue - LS1TECH - Camaro and Firebird Forum Discussion

Notices
Generation IV Internal Engine 2005-2014 LS2 | LS3 | LS7 | L92 | LS9

LS3 possible balance issue

 
Old 03-13-2019, 11:46 AM
  #1  
Teching In
Thread Starter
 
Join Date: Dec 2016
Posts: 18
Default LS3 possible balance issue

Recent rebuild of a stroker LS3, compstar crank and rods with wiseco pistons. During rebuild I changed from a -2 piston to a -15 dish. Machine shop re-balanced and everything went back together great. Now that is back together I have a vibration at a very specific 1800 RPM. car has 500 miles on it now and runs like a champion but that engine vibration bugs me.

Stock balancer
Circle D converter/TH400


I really want to blame either the converter or flex plate but stock balancer makes me want an innovations west balancer. I would love some input, I am trying to avoid the inevitable, that the machine shop messed up the balance.
hillshooter is offline  
Old 03-14-2019, 09:34 AM
  #2  
TECH Fanatic
 
bbond105's Avatar
 
Join Date: May 2012
Location: Poplarville, MS
Posts: 1,256
Default

Unbolt the torque converter push it back from the flex plate, run the up engine and see if the vibration is still there.
bbond105 is offline  
 


Thread Tools
Search this Thread

About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: