Notices
PCM Diagnostics & Tuning HP Tuners | Diablo | Pantera EFI

6.0l no spark

 
Old 08-07-2018, 09:08 PM
  #1  
TECH Apprentice
Thread Starter
 
Drj8787's Avatar
 
Join Date: May 2010
Posts: 342
Default 6.0l no spark

I put a reman 6.0l in my buddies truck its a 03 2500hd so it had the 6.0 in to start with. After getting everything back in a hooked up I'm not getting any spark and it wont start. I've checked everything over a couple times. Checked and moved cleaned all grounds on the back of the heads and side of the block. Checked for 12v on the wiring harness at the coils its good. I'm getting rmp when I log on HPT so I'm 99% sure the crank sensor and wires are good there. I can smell fuel when we crank it so I'm 99% sure I'm getting plenty of fuel. I've checked everything I can think of except continuity of different wires but again I'm getting RPM on my log so I feel like things are in line there. No DTC's no Security lights on.When I probe the signal wire on the crank sensor plug I can hear it trigger stuff but don't get spark. Crank, cam, oil, knock sensors are all new. I've checked all the fuses also.

Any suggestions would be much appreciated.
Drj8787 is offline  
Old 08-09-2018, 03:03 PM
  #2  
TECH Apprentice
iTrader: (6)
 
Lsxford's Avatar
 
Join Date: Nov 2016
Location: Winfield AL
Posts: 396
Default

Have you checked it with a spark tester, or a known good spark plug stuck against the manifold? This is where I would start

If the pcm is firing the injectors it should be firing the coils.

You know it's getting fuel but is it getting too much? Not enough? What is fuel pressure?
Lsxford is offline  
Old 08-09-2018, 03:30 PM
  #3  
TECH Apprentice
Thread Starter
 
Drj8787's Avatar
 
Join Date: May 2010
Posts: 342
Default

Originally Posted by Lsxford View Post
Have you checked it with a spark tester, or a known good spark plug stuck against the manifold? This is where I would start

If the pcm is firing the injectors it should be firing the coils.

You know it's getting fuel but is it getting too much? Not enough? What is fuel pressure?
52-55psi with the IGN on not sure what its getting when cranking. I have a good old plug that i have been using and definitely not getting spark.
Drj8787 is offline  
Old 08-09-2018, 05:32 PM
  #4  
Teching In
 
Join Date: Jul 2018
Posts: 29
Default

try do a flood clear. if you can smell gas, and i'm assuming this is a stock vehicle, you may be flooded and fouled the plugs. check the harness for the coils too.
is there any codes?
try to disable the vats.
Mymonte666 is offline  
 


Thread Tools
Search this Thread

About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: