what did you do to your firebird today? - Page 3 - LS1TECH - Camaro and Firebird Forum Discussion



Pontiac Firebird 1967-2002 Birds of a feather flock together

what did you do to your firebird today?

Reply
 
Thread Tools Search this Thread
Old 03-11-2010, 06:56 PM   #41
11 Second Club
iTrader: (8)
 
SweeTbone's Avatar
 
Join Date: Feb 2005
Location: Toledo, OH
Posts: 2,537
Default

Haven't even started insurance back on it yet this year. Still sitting in the garage under a car cover. Walked through the garage to get a Monster energy drink, so I kinda saw a big gray blob out of the corner of my eye.
SweeTbone is offline   Reply With Quote
Old 03-11-2010, 07:05 PM   #42
TECH Enthusiast
iTrader: (3)
 
Join Date: May 2009
Location: NJ
Posts: 558
Default

A family friend just bought a shop, so I took my car over there so I could use his lift. I put in my swaybars, zip tied some loose wires, and made his employees jealous when I pulled into the shop.
Pseudonym is offline   Reply With Quote
Old 03-11-2010, 07:22 PM   #43
That's MISTER MODERATOR
iTrader: (9)
 
Paul Bell's Avatar
 
Join Date: Nov 2005
Location: NYC
Posts: 7,341
Default

I installed the following items pulled from the ‘94:

Jacked up the car onto four 13 inch blocks under the tires;
UMI 3 point sub frame connectors;
UMI torque arm;
UMI torque arm relocator with drive shaft safety loop;
UMI lower control arms;
UMI panhard brace & double adjustable panhard bar;
Poly transmission mount;
Oil & filter change;
Fuel filter.

OK, the filters & oil weren’t from the ‘94.

Then I went and had lunch.
Paul Bell is offline   Reply With Quote
Old 03-12-2010, 09:21 AM   #44
'Bird Director
iTrader: (80)
 
y2k_ta's Avatar
 
Join Date: Dec 2001
Location: Central Indiana Honors: 4th grade spelling bee contestant
Posts: 12,736
Default

I put a second coat of POR-15 on the rear end that I'm going to be putting in my '95. Once it dries from the rain, I'm gonna shoot it with some flat black paint.
y2k_ta is offline   Reply With Quote
Old 03-12-2010, 12:21 PM   #45
Launching!
iTrader: (10)
 
TransAmdriv3r's Avatar
 
Join Date: Sep 2007
Location: wapwallopen, pa
Posts: 260
Default

took the trans am out mug bogging... well not quite, the snow is melting and it muddy everywhere. Its my daily driver right now, but I just washed it yesterday and had it on ramps. sprayed the underside with simple green and then pressure washed it. Looked like it had mad diarrhea running out from it. lol
TransAmdriv3r is offline   Reply With Quote
Old 03-12-2010, 12:28 PM   #46
TECH Apprentice
iTrader: (16)
 
98PurpleT/A's Avatar
 
Join Date: Jun 2005
Location: Ft. Lauderdale, FL
Posts: 343
Unhappy

Watched her sit in the rain ans wished I had a garage for her to sleep in
98PurpleT/A is offline   Reply With Quote
Old 03-12-2010, 06:19 PM   #47
Staging Lane
 
Join Date: Feb 2008
Location: Southern NH
Posts: 66
Default

I did a tune up and from my impression of the plugs, they appeared to be the stock plugs/wires ( I haven't driven the car much in the 2 years I've owned it)70k miles on the odo, did an oil change and lastly put some black ZR1's with machined lip on her.
kct385 is offline   Reply With Quote
Old 03-13-2010, 01:42 PM   #48
TECH Regular
iTrader: (6)
 
ta-stanger's Avatar
 
Join Date: Jul 2009
Location: Lake Of the Ozarks, MO.
Posts: 499
Default

Just gave it a pat on the *** cuz it's raining here again. God I'm glad I got a truck to:>
ta-stanger is offline   Reply With Quote
Old 03-13-2010, 02:00 PM   #49
TECH Apprentice
iTrader: (1)
 
Endersshadow's Avatar
 
Join Date: Aug 2009
Posts: 378
Default

I installed new headlights and a new right rear turn signal bulb. I also took it for an oil change (can't do it myself right now as I'm injured). I love my Formula.
Endersshadow is offline   Reply With Quote
Old 03-13-2010, 03:13 PM   #50
That's MISTER MODERATOR
iTrader: (9)
 
Paul Bell's Avatar
 
Join Date: Nov 2005
Location: NYC
Posts: 7,341
Default

I took my baby out for a swim in the heavy rains we're getting here in NYC.

Something's banging around out back, sounds like I left every freekin bolt hand-tight. I know the Y-pipe is up against the T/A reinforcement bar. I need to BFH it. Trying to book time on a friends lift.
Paul Bell is offline   Reply With Quote
Old 03-13-2010, 06:04 PM   #51
Registered User
 
SLVERWS6's Avatar
 
Join Date: Feb 2010
Location: Crapsonville, FL
Posts: 13
Default

Just a little wash n' wax. Had to clean her up for a hot date tonight, we're going out to eat some rice! Hahhahaha!!
SLVERWS6 is offline   Reply With Quote
Old 03-13-2010, 06:48 PM   #52
TECH Fanatic
iTrader: (1)
 
hawk584's Avatar
 
Join Date: May 2006
Location: earth
Posts: 1,679
Default

i made another car payment...
hawk584 is offline   Reply With Quote
Old 03-13-2010, 08:15 PM   #53
TECH Apprentice
iTrader: (16)
 
98PurpleT/A's Avatar
 
Join Date: Jun 2005
Location: Ft. Lauderdale, FL
Posts: 343
Default

I installed a WS6 radiator support, stainless steel lid and cut hood to allow air to flow like it would on a WS6.
98PurpleT/A is offline   Reply With Quote
Old 03-13-2010, 08:16 PM   #54
TECH Apprentice
iTrader: (16)
 
98PurpleT/A's Avatar
 
Join Date: Jun 2005
Location: Ft. Lauderdale, FL
Posts: 343
Default

Quote:
Originally Posted by Endersshadow View Post
I installed new headlights and a new right rear turn signal bulb. I also took it for an oil change (can't do it myself right now as I'm injured). I love my Formula.
Get well soon




Quote:
Originally Posted by SLVERWS6 View Post
Just a little wash n' wax. Had to clean her up for a hot date tonight, we're going out to eat some rice! Hahhahaha!!
Funny, My car likes rice too.
98PurpleT/A is offline   Reply With Quote
Old 03-14-2010, 12:44 PM   #55
Launching!
iTrader: (3)
 
Join Date: Jan 2007
Location: New Braunfels/Mission, TX
Posts: 276
Default

A wash and wax last night.
Pitbull329 is offline   Reply With Quote
Old 03-14-2010, 10:24 PM   #56
On The Tree
iTrader: (8)
 
Join Date: Jan 2007
Location: Asheville, NC
Posts: 138
Default

Like others, thought about driving it . It's been sitting since last summer and finally starting to get it back on the road, hopefully next week.
=Tac= is offline   Reply With Quote
Old 03-15-2010, 09:50 AM   #57
Teching In
 
sckLS1T/A's Avatar
 
Join Date: Aug 2009
Location: PA
Posts: 3
Default

i installed adjustable lca's hotchkis springs and a new diff cover yesterday!! I just purchased some drilled and sloted rotors that im going to put on after i powder coat the calipers!! cant wait till this rain is done with and all the salt is off of the roads!!
sckLS1T/A is offline   Reply With Quote
Old 03-15-2010, 11:13 AM   #58
TECH Resident
iTrader: (5)
 
WarShrike's Avatar
 
Join Date: Sep 2006
Location: Lubbock, TX
Posts: 799
Default

Progress, just a little. Bout to lay down the gaskets for the lower intake manifold and let it set up. This is after having to replace the leaky MLS gaskets. Did a different treatment that quite a few guys in the Grand National community are having to do and now hoping this will work out for the better.
WarShrike is offline   Reply With Quote
Old 03-16-2010, 11:57 PM   #59
Staging Lane
iTrader: (23)
 
Doobie52's Avatar
 
Join Date: Jun 2009
Location: Henderson, NV
Posts: 97
Default

I finished installing my new FAST intake!

Doobie52 is offline   Reply With Quote
Old 03-17-2010, 07:07 PM   #60
On The Tree
iTrader: (8)
 
Join Date: Jan 2007
Location: Asheville, NC
Posts: 138
Default

Finished removing the rest of my A/C. Wired in a bulb socket for my driver side DRL. Relocated hood latch cable to fender well. Remounted trans cooler on the radiator. Topped off my Power Steering and Coolant. Found a cool rock in the front bumper (round radiator bottom) and threw it into a bush. Cleaned rear hatch and cleaned out rear area. Removed any extra "stuff" in the radiator/drl area.

Tomorrow, putting in new DRL housings and maybe getting my PCM back from Frost. Whenever I do get the PCM back going to get it inspected and retagged for the road!
=Tac= is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough idle when cold, help! 93BlackZ28 LT1-LT4 Modifications 17 07-24-2009 01:58 PM
Cars starts missing after warm up? Abe99 General Maintenance & Repairs 2 11-11-2007 05:34 AM
how long do you warm up ls1 in cold rxrom New LS1 Owners - Newbie Tech 19 02-01-2007 10:52 AM
Do you warm your car up? Optimus_Prime New LS1 Owners - Newbie Tech 112 04-24-2006 07:09 PM
Those with dual valve springs. How long do you let you car warm up? shep28 Generation III Internal Engine 31 05-27-2005 03:28 PM


Tags
02, boot, firebird, free, lebanon, ls1, mo, mobil, nationals, noise, pics, shift, solution, transam, trim

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:36 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send