fuel pump not getting power - LS1TECH



Fueling & Injection Fuel Pumps | Injectors | Rails | Regulators | Tanks

fuel pump not getting power

Reply
 
Thread Tools Search this Thread
Old 12-31-2009, 08:15 PM   #1
TECH Resident
Thread Starter
iTrader: (4)
 
pdasterly's Avatar
 
Join Date: Jun 2007
Posts: 845
Default fuel pump not getting power

pump not getting power with the key, i can jump the relay under the hood and the pump willl come on but not with the key. I pinned my balancer to the crank and pulled the radiator, is there something i could have cut or broke. Grounds are ok, 1 on the driver side near the motor mount and three on the rear of the driver side head
pdasterly is offline   Reply With Quote
Old 12-31-2009, 10:08 PM   #2
TECH Fanatic
iTrader: (2)
 
Join Date: Feb 2004
Location: rosemount,mn/windsor locks,ct
Posts: 1,111
Default

get a electrical diagram for the fuel pump and check the associated ground.
99huggerorangeZ is offline   Reply With Quote
Old 01-01-2010, 03:11 AM   #3
TECH Resident
Thread Starter
iTrader: (4)
 
pdasterly's Avatar
 
Join Date: Jun 2007
Posts: 845
Default

if the pump was bad or the ground, why am i able to start the car with the fuel pump relay jumped(bypasssed). Its like the pcm is not talking to the pump
pdasterly is offline   Reply With Quote
Old 01-01-2010, 05:52 AM   #4
TECH Apprentice
 
intense3123's Avatar
 
Join Date: May 2006
Posts: 343
Default

have you tried a new relay?
intense3123 is offline   Reply With Quote
Old 01-01-2010, 12:11 PM   #5
TECH Resident
Thread Starter
iTrader: (4)
 
pdasterly's Avatar
 
Join Date: Jun 2007
Posts: 845
Default

i switched relays(grey box). Fuse is good also.
pdasterly is offline   Reply With Quote
Old 01-01-2010, 01:11 PM   #6
On The Tree
iTrader: (22)
 
quews6lime's Avatar
 
Join Date: Aug 2009
Location: creole cockpit
Posts: 102
Default

check relays and fuses
quews6lime is offline   Reply With Quote
Old 01-02-2010, 03:24 PM   #7
TECH Resident
Thread Starter
iTrader: (4)
 
pdasterly's Avatar
 
Join Date: Jun 2007
Posts: 845
Default

the wire broke when i pinned the crank near the radiator
pdasterly is offline   Reply With Quote
Old 01-23-2010, 02:37 PM   #8
Staging Lane
iTrader: (17)
 
Join Date: Dec 2009
Location: dallas tx
Posts: 87
Default

what wire was it im having the same problem after installing a FAST intake and new valve springs
9Green-Z8 is offline   Reply With Quote
Old 03-13-2010, 10:43 PM   #9
Staging Lane
iTrader: (17)
 
Join Date: Dec 2009
Location: dallas tx
Posts: 87
Default

i found my wire problem
9Green-Z8 is offline   Reply With Quote
Old 03-13-2010, 10:44 PM   #10
Staging Lane
iTrader: (17)
 
Join Date: Dec 2009
Location: dallas tx
Posts: 87
Default

it was the ground wire right behind the driver side head it was cut
9Green-Z8 is offline   Reply With Quote
Old 03-13-2010, 10:45 PM   #11
Staging Lane
iTrader: (17)
 
Join Date: Dec 2009
Location: dallas tx
Posts: 87
Default

i was swapping intakes and valve springs i guess it got cought somehow
9Green-Z8 is offline   Reply With Quote
Old 05-28-2010, 08:11 PM   #12
Registered User
 
Join Date: May 2010
Location: Georgia
Posts: 4
Default

I'm having the same issue. I have no power to my fuel pump, just recently installed a new pump. The relay and fuse is good. When I tried to jump the relay, I popped the fuse, anyone know why? Could it be a bad wire? About to pull my hair out here, any suggestions greatly appreciated.
Chris O is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Racetronix dual pump hotwire kit. GrnGoblin Fueling & Injection 6 08-10-2016 10:16 PM
2001 WS6 Will not turn off after removing key esriderok Pontiac Firebird 1967-2002 3 05-25-2016 08:06 AM
Power Steering Setups... Turnin20s LT1-LT4 Modifications 5 03-01-2011 02:27 PM
Fuel Pump pressure test and other ? Stu Cool Conversions & Hybrids 3 04-05-2006 04:48 PM
No start and engine will not rotate. MJK General Maintenance & Repairs 35 03-31-2006 04:34 PM


Tags
1981, 2000, 53, 98, camaro, camino, chevy, el, fuel, fuse, geting, ls, power, pump, z28

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:05 PM.