guys please help fast , g6x3 on camaro !! - LS1TECH

Log In 


Generation IV External Engine LS2 | LS3 | LS7 | L92 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories

guys please help fast , g6x3 on camaro !!

Reply
 
Thread Tools Search this Thread
Old 06-20-2012, 04:06 PM   #1
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 3
Default guys please help fast , g6x3 on camaro !!

hi guys

we r so shocked . QQ

we have 2010 camaro M6 ls3 , we installed g6x3 cam + 102 fast + 102 NW throtle

but the .. we got 430 hp on dyno !! ( it was 414 with bolt-ons)

car has
vararam CAI
american racing headers + x pipe


so how it goes like this? only 16 hp gain from 102 intake + g6x3?

also we tryed it on street , and its almost same as bolt-ons , not gains



my friend is so sad now and please we need your help fast
sirmo7 is offline   Reply With Quote
Old 06-20-2012, 04:15 PM   #2
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 3
Default

this is the cam paper
Attached Thumbnails
guys please help fast , g6x3 on camaro !!-img-20120621-wa0000-1-.jpg  
sirmo7 is offline   Reply With Quote
Old 06-20-2012, 04:21 PM   #3
TECH Regular
iTrader: (1)
 
Join Date: Sep 2007
Posts: 499
Default

what valve springs you use?
blackonblacksls is offline   Reply With Quote
Old 06-20-2012, 04:21 PM   #4
TECH Regular
iTrader: (1)
 
Join Date: Sep 2007
Posts: 499
Default

i used one of these with tsp .650 lift springs and it floated the valves and had ptv and ran slower and slower till I pulled the motor.
blackonblacksls is offline   Reply With Quote
Old 06-20-2012, 04:25 PM   #5
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 3
Default

patriot extreme .660
sirmo7 is offline   Reply With Quote
Old 06-22-2012, 05:28 PM   #6
TECH Regular
iTrader: (1)
 
Join Date: Sep 2007
Posts: 499
Default

I was told to use the comps and I wouldn't have had any issues.
blackonblacksls is offline   Reply With Quote
Old 06-22-2012, 09:23 PM   #7
Staging Lane
 
AJG383's Avatar
 
Join Date: Nov 2011
Posts: 65
Default

Something is wrong, you should be around 470-480 rwhp with that setup.
AJG383 is offline   Reply With Quote
Old 07-04-2012, 09:56 AM   #8
On The Tree
iTrader: (5)
 
DaFireMan's Avatar
 
Join Date: Aug 2010
Location: Chilly Gentilly
Posts: 150
Default

Quote:
Originally Posted by sirmo7 View Post
this is the cam paper
yea somethings going on in there who did the install?
DaFireMan is offline   Reply With Quote
Old 07-08-2012, 03:19 PM   #9
TECH Junkie
iTrader: (1)
 
FIREHAWK #07's Avatar
 
Join Date: Nov 2004
Location: TX
Posts: 3,215
Default

Where did you get the specs from? Aren't those 'top secret'?
FIREHAWK #07 is offline   Reply With Quote
Old 07-08-2012, 03:25 PM   #10
Custom User Title
iTrader: (21)
 
5w20's Avatar
 
Join Date: Oct 2003
Location: Houston , Tx
Posts: 3,416
Default

This is with comp 921's. It ran fine for months, just noticed this while doing some upgrades.



5w20 is offline   Reply With Quote
Old 07-09-2012, 06:36 PM   #11
12 Second Club
iTrader: (20)
 
litle88's Avatar
 
Join Date: Jan 2007
Location: Burbank, Illinois
Posts: 2,548
Default

I would look into the comp 926 springs they are good for .675 and have really good seat and open pressures. Just my .2

I guess it's not a secret any more lol, if they are right I thought it was a bigger cam than I thought. Not bad though but there are better cams for sure lol
litle88 is offline   Reply With Quote
Old 07-09-2012, 11:25 PM   #12
TECH Regular
iTrader: (1)
 
Join Date: Sep 2007
Posts: 499
Default

I don't think any other cam has consistenly shown as good of results as the g6x3. But also it's aggressive as **** compared to what most guys run. I can see why so many have spring issues.
blackonblacksls is offline   Reply With Quote
Old 07-10-2012, 01:40 PM   #13
12 Second Club
iTrader: (1)
 
hivoltagedriver's Avatar
 
Join Date: Sep 2006
Location: Owasso, OK
Posts: 531
Default

Was the cam installed a tooth off maybe. I have seen that happen, and the car will not make anywhere near the power that it should.
hivoltagedriver is offline   Reply With Quote
Old 07-10-2012, 08:43 PM   #14
Custom User Title
iTrader: (21)
 
5w20's Avatar
 
Join Date: Oct 2003
Location: Houston , Tx
Posts: 3,416
Default

Quote:
Originally Posted by hivoltagedriver View Post
Was the cam installed a tooth off maybe. I have seen that happen, and the car will not make anywhere near the power that it should.
No, the car made power.
5w20 is offline   Reply With Quote
Old 07-11-2012, 12:44 AM   #15
TECH Apprentice
iTrader: (12)
 
bamaballa205's Avatar
 
Join Date: Nov 2007
Location: Mayport, FL
Posts: 351
Default

Quote:
Originally Posted by 5w20 View Post
This is with comp 921's. It ran fine for months, just noticed this while doing some upgrades.



Did u notice any type of power loss or valve train noise?
bamaballa205 is offline   Reply With Quote
Old 07-11-2012, 02:39 AM   #16
Custom User Title
iTrader: (21)
 
5w20's Avatar
 
Join Date: Oct 2003
Location: Houston , Tx
Posts: 3,416
Default

Quote:
Originally Posted by bamaballa205 View Post
Did u notice any type of power loss or valve train noise?
It did lose about 10-15 on the dyno, but that was hardly noticeable in "mexico".
5w20 is offline   Reply With Quote
Old 07-11-2012, 01:20 PM   #17
12 Second Club
iTrader: (1)
 
hivoltagedriver's Avatar
 
Join Date: Sep 2006
Location: Owasso, OK
Posts: 531
Default

Quote:
Originally Posted by 5w20 View Post
No, the car made power.
Apparently it didn't make the power you were looking for. If that's all the power you gained from a healthy cam swap and the FAST, it could definitly be off a tooth, even if it gained a couple of hp from the baseline run. I've seen it happen in person. Might be something to check - or not. Whatever floats your boat. Either that, or the tune is WAY off.
hivoltagedriver is offline   Reply With Quote
Old 07-11-2012, 09:21 PM   #18
Custom User Title
iTrader: (21)
 
5w20's Avatar
 
Join Date: Oct 2003
Location: Houston , Tx
Posts: 3,416
Default

Quote:
Originally Posted by hivoltagedriver View Post
Apparently it didn't make the power you were looking for. If that's all the power you gained from a healthy cam swap and the FAST, it could definitly be off a tooth, even if it gained a couple of hp from the baseline run. I've seen it happen in person. Might be something to check - or not. Whatever floats your boat. Either that, or the tune is WAY off.
You have my situation and the OP's mixed up.

That cam was worth about 60 rwhp in the situation I'm talking about. Later on it was noticed that the car was down about 10-15 rwhp after taking it back to get retuned because some things were added. All is fixed now and is making more power than ever do to even more upgrades. Cam isn't a tooth off nor is the tune off...


Quote:
Originally Posted by AJG383 View Post
Something is wrong, you should be around 470-480 rwhp with that setup.

Even without the 102 FAST setup and the stock LS3 stuff it should make that.
5w20 is offline   Reply With Quote
Old 07-12-2012, 08:22 AM   #19
12 Second Club
iTrader: (1)
 
hivoltagedriver's Avatar
 
Join Date: Sep 2006
Location: Owasso, OK
Posts: 531
Default

Yeah, my posts were intended for the OP. not sure how I missed that that's not where they were being directed.
hivoltagedriver is offline   Reply With Quote
Old 07-12-2012, 09:46 PM   #20
On The Tree
iTrader: (1)
 
G8-4-speed's Avatar
 
Join Date: Jan 2009
Location: Hope Mills, NC
Posts: 115
Default

How the hell did you get a 235 duration .647" lift cam to clear the pistons on a 107ICL?!?!
G8-4-speed is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FAST 102 gains over ported LS3 intake in bolt-on 6.0L G8 Patrick G Dynamometer Results & Comparisons 37 03-19-2015 12:48 PM
L92 heads off, AFR 230 V2 heads on, 504rwhp 6.0L automatic! (now with track results). Patrick G Dynamometer Results & Comparisons 232 02-12-2011 02:05 PM
L92 heads off, AFR 230 V2 heads on, 504rwhp 6.0L automatic! Patrick G Generation III Internal Engine 48 10-07-2010 01:52 PM
here we go again with intake swaps. mike c. Generation IV External Engine 10 07-17-2010 12:34 PM
FAST 102 gains over ported LS3 intake in bolt-on 6.0L G8 Patrick G Generation IV External Engine 36 04-17-2010 03:01 AM


Tags
bolt, camaro, camarowguy, camshaft, fastest, g6x3, guys, ls1tech, ls2, ls3, ons, packages, swap, tooth, tune

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:03 PM.