View Full Version : Car wont start clicking sound


jhpeyto
07-26-2012, 02:44 PM
So i removed my center console to put in some shifted boots. When i put everything back together my car won't start. When the key is in the ignition it will make the beeping sound to let me know my lights are on or i left my keys in the ignition. When i turn it over nothing happened car goes silent. Any ideas? my only thought is maybe a lose wire or something but i have no idea bow to check that.

Bacon
07-26-2012, 02:53 PM
That sounds more like a dead battery than anything else. The clicking is likely the starter and due to low voltage. Check your battery and if its good, clean the terminals (even if they look clean) with a wire brush.

clonedws6
07-26-2012, 02:55 PM
Dead battery

badformulaLS1
07-26-2012, 03:01 PM
I'm not sure if your car is or isnt making a sound when you turn the key (says clicking sound in title then in post says car goes silent) but I might be having a similar issue. Car was running perfectly fine yesterday and today I try to start it and nothing happens at all. No clue whats wrong with it.

jhpeyto
07-26-2012, 03:10 PM
guess i should clear that up, the clicking sound is when i remove the key it keeps clicking for awhile. would the car still make the beeping sound if the battery is dead?

jhpeyto
07-26-2012, 03:43 PM
I'm an idiot, it was the battery. Jumped it from my wifes car & it started just fine. It was sitting in my garage for 2 days while some of the paint dried, guess something was left on that ran down the battery.

Bacon
07-26-2012, 03:55 PM
Yes it will still make a beeping sound. Your dome light and headlights might even work a little bit, but it wont have enough juice to turn it over. Cranking take a lot of power.

clonedws6
07-26-2012, 03:56 PM
My gto has a terrible battery and if I leave it sitting itll die. I go through this alot. lol

White6SpdZ28
07-27-2012, 03:34 AM
battery

1999CamaroSS
07-27-2012, 03:40 AM
the "click" is the pin in your starter motor engaging, but if there isn't enough voltage, the gear on that shaft won't spin (engine wont start). need a new battery/alternator.....