Automatic Transmission - Urgent help




View Full Version : Urgent help


muayyadf1
10-23-2007, 08:01 PM
Hi,


I'm installing transgo and when I came to install the valve that has a snap ring I mistakely removed the other valve with the smaller snap ring and I don't know how to install it..I'm in deep $#!t now. can any one tell me please..quickly.



:confused:


Thanks


muayyadf1
10-23-2007, 08:25 PM
it's this one


http://www.eatmyshifts.com/77805.jpg

Gilbert@Ace Racing
10-23-2007, 08:26 PM
Ok... is that the valve that you removed mistakenly?

g


Gilbert@Ace Racing
10-23-2007, 08:33 PM
Well lets presume it is the valve you removed mistakenly.

There are two springs, an inner and outer... they go in first.

Then insert the valve just as it is in the photo you provided.

Then install the small circular valve stop plate... the round disc with the hole in it.

Then depress the valve and install the snap ring.

g

muayyadf1
10-23-2007, 09:03 PM
Thanks very much.


I'm reliefed now, so the fatter end goes on the valve stop?

2 springs

valve, thin side up

valve stop


am I right?


it's in the case BTW.


Thank you.

Vince @ FLT
10-23-2007, 10:08 PM
Here is a line up for you.
http://i110.photobucket.com/albums/n97/Vinceflt/100_0141.jpg

Gilbert@Ace Racing
10-23-2007, 10:17 PM
Dang Vince, you coulda washed that stuff first dude. :engarde:

g

Vince @ FLT
10-23-2007, 10:44 PM
LOL!!!!!! I took that pic last year. Believe it or not that came out of somebody else's fresh rebuilt. Scary huh?:D

muayyadf1
10-23-2007, 11:10 PM
thank you very much for the help.


you never let me donwn (search information)



best regards

muayyadf1
10-24-2007, 02:46 PM
everything is assembled now and drive tested.


car shifts every gear without a problem. I used one spacer in the 2nd accumulator and done everything else except servo 2nd gear piston spring because of clearence problem but I only did adjust the band by one golden ring. Car shifts are nice and crisp. much better than the stupid oem setup. I'm much happier with her :D


Thank you all for the love of help.

Gilbert@Ace Racing
10-24-2007, 03:19 PM
Congrats. Glad it worked out for you like it did!

g

muayyadf1
10-26-2007, 05:59 AM
I think I'm getting a problem now. My 2-3 shift at partial throttle are not as good as other shifts that are crisp. when I floor it, shifts OK.

sometimes when it shift RPM jumps up alittle them goes down. On power mode it doesn't do it. (performance shifts). is it TM ? or tuning problem (stock tune). I just noticed it. it was there before the shift kit but not noticible.


any help would be appreciated.

Vince @ FLT
10-26-2007, 06:44 AM
From what you are describing either TM is the issue or you have a timing issue with the band releasing and the 3-4 clutch applying. You have a couple options. Remove the TM see if that helps. Readjust the band by making it tighter. Or maybe increase the feed hole size for the 3rd gear shift. Let us know what you come up with. Vince

muayyadf1
10-26-2007, 04:10 PM
The strange thing is that 2-3 feed hole was already 0.093 hole, I didn't want to go with 0.101 hole because it is specified for hi-stall or full race usage.
and for the band, I tried to use both golden spacers, It wasn't moving when I tried to move it 1/8 inch at least. so I went with one. I'm getting my hp tuners soon. I hope this fixes it.


Thanks in advance.

Gilbert@Ace Racing
10-26-2007, 04:40 PM
What converter are you running?

g

muayyadf1
10-26-2007, 04:41 PM
stock

Gilbert@Ace Racing
10-26-2007, 04:47 PM
I see. Well there aren't too many options, go with what Vince suggested and see what happens. Start with the less invasive moves 1st. Tune and servo adjustment to begin with.

g

muayyadf1
10-29-2007, 04:44 PM
hi again,


today I got my hp tuners, so I thought I would try to reduce TM and increase partial throttle line pressure. I did and it's more alive now and shifts just like what I wanted. In the begining I removed TM, didn't like the way it shifted. So I put it back reduced by 40% (there was alot of it). I'm glad it was a software problem and it's solved. My max line pressure is 90. like what i'm told when having a transgo installed.


thank you Vince and gilbert for your help and for standing with me in this one. thank you very much.

time for tuning :eyes:

Gilbert@Ace Racing
10-29-2007, 05:09 PM
At what point is max line pressure 90? And is that 90 psi?

And, you are welcome. Glad I could help. And if Vince weren't slacking off somewhere right now he would be here to to say " You're welcome. I get a big kick out of doing good things for good folks like yourself!" :D

g

muayyadf1
10-30-2007, 02:23 AM
That would be 90% of line pressure the tranny can deliver.


and about the big kick out, I never do that for respectful people like you:angel:.



best regards

muayyadf1
12-09-2007, 06:58 AM
Today I pulled the pan and valve body because I was getting some slippage at part throttle body even after tuning.


Pulled the valve body to check the check balls. There was a ball not in the right place. The one that sits with another check ball. I realigned it and then tested the car. It's much better now with minimal slippage and it's getting less and less with tuning.


When I pulled the pan there was some shavings like I have driven the car for 30K miles but it's only 3K miles! but the oil was pretty red. Do you think the trans is widely harmed? I guess the check ball problem gave the clutched less oil. My transmission never got temperature more than 185F.


Wanted to share my experience to benifit.


Thanks

performabuilt
12-09-2007, 09:53 AM
Today I pulled the pan and valve body because I was getting some slippage at part throttle body even after tuning.


Pulled the valve body to check the check balls. There was a ball not in the right place. The one that sits with another check ball. I realigned it and then tested the car. It's much better now with minimal slippage and it's getting less and less with tuning.


When I pulled the pan there was some shavings like I have driven the car for 30K miles but it's only 3K miles! but the oil was pretty red. Do you think the trans is widely harmed? I guess the check ball problem gave the clutched less oil. My transmission never got temperature more than 185F.


Wanted to share my experience to benifit.


Thanks

If the trans spent much time slipping at all and you have material in the pan, It is likly substaintial damage has been done :(