Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Nitrous Oxide
Sign in using an external account
Register Forgot Password?
Search

Nitrous Oxide
Installation | Tuning | Products

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 07-16-2006, 11:54 AM   #1
TECH Fanatic
Garage is empty, add now
 
SLP4CamaroSS's Avatar
 
Trader Rating: 15
Join Date: Nov 2004
Location: Lawton, ok
Posts: 1,246
Send a message via AIM to SLP4CamaroSS
Default 06 gto nitrous?

frind got a 06 gto and bought a vette nitrous system cuz of the electronic throttle is there a way to hook it up?
__________________
2000 Camaro SS #3938 M6 magnaflow catback, TDP stage 3 clutch, ASP UD pulley, ls6 intake, g5x3 112lsa, pacesetter tsp y pipe, pp gold spring, ls7 lifters, 4.10, UMI subframe/LG LCAs etc.....and hptuners done by me

www.fquick.com/Ls14CamaroSS
SLP4CamaroSS is offline   Reply With Quote
Old 07-16-2006, 11:58 AM   #2
TECH Fanatic
Garage is empty, add now
 
SLP4CamaroSS's Avatar
 
Trader Rating: 15
Join Date: Nov 2004
Location: Lawton, ok
Posts: 1,246
Send a message via AIM to SLP4CamaroSS
Default

i think he got a nx vette kit
__________________
2000 Camaro SS #3938 M6 magnaflow catback, TDP stage 3 clutch, ASP UD pulley, ls6 intake, g5x3 112lsa, pacesetter tsp y pipe, pp gold spring, ls7 lifters, 4.10, UMI subframe/LG LCAs etc.....and hptuners done by me

www.fquick.com/Ls14CamaroSS
SLP4CamaroSS is offline   Reply With Quote
Old 07-16-2006, 03:28 PM   #3
11 Second Club
Garage is empty, add now
 
1MEANGTO's Avatar
 
Trader Rating: 0
Join Date: Aug 2004
Location: minneapolis,mn
Posts: 891
Send a message via AIM to 1MEANGTO
Default

http://www.nitrousdirect.com/nitrous...oto=99&cat=507

Heres how he needs to hook up the wot switch. It5 works flawless on my car.
__________________
2004 GTO Cosmos Purple A4 - 11.07 @ 127.44 Old Bottle Setup
408 E85 gt47-88,50 shot NX ,turbo 400,9" currie

2005 Yellow Jacket GTO A4 - 11.53 @ 121 stock w/150 Shot 1.8 60' old setup
Nitrous outlet ls2 plate kit 150 shot,275/40's,powerslots,baby cam,sw lt headers,
417 rwhp and 397 torque E85tune
582 rwhp and 676 torque (150 shot)
ALL Tuned by me

Last edited by 1MEANGTO; 07-16-2006 at 03:34 PM..
1MEANGTO is offline   Reply With Quote
Old 07-16-2006, 03:41 PM   #4
TECH Senior Member
Garage is empty, add now
 
Robert56's Avatar
 
Trader Rating: 2
Join Date: Aug 2003
Location: Tacoma, WA
Posts: 9,562
Default

Are you talking about the TPS (throttle position switch) that comes in the kit?
Robert
__________________
'02 Z06, 408 LQ9, Direct Port Dry and 3-Stgs on stk PCM,
644rwhp 718rwtq-old setup
http://www.fquick.com/robert56

Robert56 is offline   Reply With Quote
Old 07-17-2006, 10:22 AM   #5
Launching!
Garage is empty, add now
 
FinalTA's Avatar
 
Trader Rating: 1
Join Date: Jul 2002
Location: Lexington, KY, USA
Posts: 291
Default

Quote:
Originally Posted by 1MEANGTO
http://www.nitrousdirect.com/nitrous...oto=99&cat=507

Heres how he needs to hook up the wot switch. It5 works flawless on my car.
I don't thing I have enough metal on my 05 GTO pedal to bolt on the WOT switch like you did. Did you have to do anything special there?

-Jason
__________________
2005 Phantom Black GTO
Blower and stuff...
527RWHP/515RWTQ
http://www.kyhorsepower.com
FinalTA is offline   Reply With Quote
Old 07-17-2006, 10:27 AM   #6
Closed ex-Sponsor Account
Garage is empty, add now
 
Trader Rating: 1
Join Date: Jul 2004
Location: Wichita Falls, TX
Posts: 2,801
Send a message via AIM to NXRICKY
Default

Quote:
Originally Posted by SLP4CamaroSS
frind got a 06 gto and bought a vette nitrous system cuz of the electronic throttle is there a way to hook it up?
If you got the single piece maf system, the tps switch will connect to your green wire on the tps sensor, red goes to toggle acc, black to ground, and pink to relay 86 pin.

Ricky
NXRICKY is offline   Reply With Quote
Old 07-17-2006, 03:39 PM   #7
11 Second Club
Garage is empty, add now
 
1MEANGTO's Avatar
 
Trader Rating: 0
Join Date: Aug 2004
Location: minneapolis,mn
Posts: 891
Send a message via AIM to 1MEANGTO
Default

Quote:
Originally Posted by FinalTA
I don't thing I have enough metal on my 05 GTO pedal to bolt on the WOT switch like you did. Did you have to do anything special there?

-Jason
Nothing special just used what came with the kit. It is pretty tight but I have done it on other gto's also including a 06.
__________________
2004 GTO Cosmos Purple A4 - 11.07 @ 127.44 Old Bottle Setup
408 E85 gt47-88,50 shot NX ,turbo 400,9" currie

2005 Yellow Jacket GTO A4 - 11.53 @ 121 stock w/150 Shot 1.8 60' old setup
Nitrous outlet ls2 plate kit 150 shot,275/40's,powerslots,baby cam,sw lt headers,
417 rwhp and 397 torque E85tune
582 rwhp and 676 torque (150 shot)
ALL Tuned by me
1MEANGTO is offline   Reply With Quote
Old 07-17-2006, 04:49 PM   #8
Launching!
Garage is empty, add now
 
FinalTA's Avatar
 
Trader Rating: 1
Join Date: Jul 2002
Location: Lexington, KY, USA
Posts: 291
Default

Quote:
Originally Posted by 1MEANGTO
Nothing special just used what came with the kit. It is pretty tight but I have done it on other gto's also including a 06.
Ahh...ok. My kit didn't come with a bolt to mount it on the pedal assembly like that. Did you have to drill a hole through it, and did you remove the entire pedal assembly in order to attach it?

Thanks again!
-Jason
__________________
2005 Phantom Black GTO
Blower and stuff...
527RWHP/515RWTQ
http://www.kyhorsepower.com
FinalTA is offline   Reply With Quote
Old 07-17-2006, 08:26 PM   #9
TECH Senior Member
Garage is empty, add now
 
Robert56's Avatar
 
Trader Rating: 2
Join Date: Aug 2003
Location: Tacoma, WA
Posts: 9,562
Default

Quote:
Originally Posted by FinalTA
Ahh...ok. My kit didn't come with a bolt to mount it on the pedal assembly like that. Did you have to drill a hole through it, and did you remove the entire pedal assembly in order to attach it?

Thanks again!
-Jason
There is another picture of wot mount in the wiring sticky.
Robert
__________________
'02 Z06, 408 LQ9, Direct Port Dry and 3-Stgs on stk PCM,
644rwhp 718rwtq-old setup
http://www.fquick.com/robert56

Robert56 is offline   Reply With Quote
Old 07-17-2006, 08:35 PM   #10
Launching!
Garage is empty, add now
 
FinalTA's Avatar
 
Trader Rating: 1
Join Date: Jul 2002
Location: Lexington, KY, USA
Posts: 291
Default

Quote:
Originally Posted by Robert56
There is another picture of wot mount in the wiring sticky.
Robert
Thanks Robert, but that post shows the WOT switch mounted on a mechanical throttle 04 GTO, not an '05+ that is throttle by wire...

I also just read one of your posts that indicated that WOT at the pedal may not exactly match WOT at the TB on a GTO. Should this worry me at all?
__________________
2005 Phantom Black GTO
Blower and stuff...
527RWHP/515RWTQ
http://www.kyhorsepower.com

Last edited by FinalTA; 07-17-2006 at 08:42 PM..
FinalTA is offline   Reply With Quote
Old 07-17-2006, 09:21 PM   #11
TECH Senior Member
Garage is empty, add now
 
Robert56's Avatar
 
Trader Rating: 2
Join Date: Aug 2003
Location: Tacoma, WA
Posts: 9,562
Default

Well, the GTO has one of the most aggresive TM out there. However, there are fixes (Cartech I think for one). Even if ya go with a tps, you'll still have the tm interfering with your runs. Maybe 1meanGTO has some insight on this issue, he's the GTO guy around here.
Robert
__________________
'02 Z06, 408 LQ9, Direct Port Dry and 3-Stgs on stk PCM,
644rwhp 718rwtq-old setup
http://www.fquick.com/robert56

Robert56 is offline   Reply With Quote
Old 07-17-2006, 10:04 PM   #12
11 Second Club
Garage is empty, add now
 
1MEANGTO's Avatar
 
Trader Rating: 0
Join Date: Aug 2004
Location: minneapolis,mn
Posts: 891
Send a message via AIM to 1MEANGTO
Default

Quote:
Originally Posted by Robert56
Well, the GTO has one of the most aggresive TM out there. However, there are fixes (Cartech I think for one). Even if ya go with a tps, you'll still have the tm interfering with your runs. Maybe 1meanGTO has some insight on this issue, he's the GTO guy around here.
Robert
First of all I left the pedal in the car to drill it. I did use a different bolt sorry I hadn't mentioned that. I have seen no issue with the TM yet. I have a lm-1 wideband and it doesn't show up there or on the ls2 scanner I have. We have actually chosen to leave the tm in the car it seams to actually help on the launch. It pulls the same amount of timing N/A as it does sprayed. In my mind it's kind of a safety precaution without a window switch. We spray through all the gear changes on both of our cars.

Oh I have installed a zex tps on another local car and the car had the same reaction and the scans look identical. So I don't really see the point in the tps. I don't really see any time differance between the TB and the accelerator pedal. In fact it seems just as fast as the pedal assembly that is my 04. Oh my wifes car is the 05 and you'll love to spray yours as much as she sprays hers!! Good luck go run a bottle through that thing you'll be very happy that you did!!
__________________
2004 GTO Cosmos Purple A4 - 11.07 @ 127.44 Old Bottle Setup
408 E85 gt47-88,50 shot NX ,turbo 400,9" currie

2005 Yellow Jacket GTO A4 - 11.53 @ 121 stock w/150 Shot 1.8 60' old setup
Nitrous outlet ls2 plate kit 150 shot,275/40's,powerslots,baby cam,sw lt headers,
417 rwhp and 397 torque E85tune
582 rwhp and 676 torque (150 shot)
ALL Tuned by me
1MEANGTO is offline   Reply With Quote
Old 07-17-2006, 10:16 PM   #13
TECH Senior Member
Garage is empty, add now
 
Robert56's Avatar
 
Trader Rating: 2
Join Date: Aug 2003
Location: Tacoma, WA
Posts: 9,562
Default

Quote:
Originally Posted by 1MEANGTO
First of all I left the pedal in the car to drill it. I did use a different bolt sorry I hadn't mentioned that. I have seen no issue with the TM yet. I have a lm-1 wideband and it doesn't show up there or on the ls2 scanner I have. We have actually chosen to leave the tm in the car it seams to actually help on the launch. It pulls the same amount of timing N/A as it does sprayed. In my mind it's kind of a safety precaution without a window switch. We spray through all the gear changes on both of our cars.

Oh I have installed a zex tps on another local car and the car had the same reaction and the scans look identical. So I don't really see the point in the tps. I don't really see any time differance between the TB and the accelerator pedal. In fact it seems just as fast as the pedal assembly that is my 04. Oh my wifes car is the 05 and you'll love to spray yours as much as she sprays hers!! Good luck go run a bottle through that thing you'll be very happy that you did!!
There you have it from a real GTO racer. Kinda what I have been preaching all along.
Robert
__________________
'02 Z06, 408 LQ9, Direct Port Dry and 3-Stgs on stk PCM,
644rwhp 718rwtq-old setup
http://www.fquick.com/robert56

Robert56 is offline   Reply With Quote
Old 07-18-2006, 09:18 AM   #14
Launching!
Garage is empty, add now
 
FinalTA's Avatar
 
Trader Rating: 1
Join Date: Jul 2002
Location: Lexington, KY, USA
Posts: 291
Default

Awesome...thanks gents!

I'm about 85% done with my hidden/dual-noid/dry setup in my '05 GTO. I love the simplicity of the dry approach and have been following posts by Robert for years now.

Happy spraying!

-Jason
__________________
2005 Phantom Black GTO
Blower and stuff...
527RWHP/515RWTQ
http://www.kyhorsepower.com
FinalTA is offline   Reply With Quote
Old 07-18-2006, 09:18 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
05, 06, 2006, gto, installation, nitrous, open, run, set, switch, throttle, wide, wire, wiring, wot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -5. The time now is 10:21 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details