Go Back  LS1TECH - Camaro and Firebird Forum Discussion > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Forced Induction
Reload this Page >

(Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS

Notices
Forced Induction Superchargers | Turbochargers | Intercoolers

(Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS

 
Old 03-06-2015, 12:48 AM
  #21  
Teching In
 
Join Date: Apr 2011
Location: Strasbourg, France
Posts: 25
Likes: 0
Received 0 Likes on 0 Posts
Default

Nice car and good project.
Where do you plan to place the turbo in the engine compartment?
I am just a few days from building the crossover for a S476 T4 in my 67 Camaro, but there isn't so much room.
Did you decide yet where to place it? Will you keep the inner wheel fenders?




67 camaro S467R
gui67 is offline  
Old 03-06-2015, 06:10 AM
  #22  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

Turbo is going on pass. Side next to water pump right above a arm shoot me your phone # or email ill text or send u a couple pics.

Last edited by gsxrred1000; 03-06-2015 at 06:12 AM. Reason: A
gsxrred1000 is offline  
Old 03-07-2015, 05:00 PM
  #23  
6D9
TECH Apprentice
iTrader: (1)
 
Join Date: Jul 2005
Posts: 380
Likes: 0
Received 0 Likes on 0 Posts
Default

Killer build! I will be following alone for sure. Some day may go this route as well.
6D9 is offline  
Old 03-07-2015, 08:50 PM
  #24  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

got mounts installed and fbody pan on.

got the hughes torque converter adapter. using stock 5.3l flexplate with this adapter.

time to drop it in. i wrestled it in there because i was trying to leave trans in and driveshaft connected. after fighting like crazy it would not sit over mounts on car. i moved the stock motor mounts forward one notch on the adapter plates and it dropped right in. issue than was the trans was back about 3/4" to far . finally decided to loosen trans mount bolts and slide trans foward. motor bolted right to trans no issue. only thing im a little leary about is when i tried connecting converter to flexplate is was about 3/8" apartand seems like it had to pull together with the bolts...... i really dont think that should be like that??? anyone chime in with suggestions... but got some good progress done anyway.
yeah i know i should of yanked hood off but im doing this build by myself and dont have much help.lol
gsxrred1000 is offline  
Old 03-07-2015, 09:12 PM
  #25  
On The Tree
iTrader: (1)
 
6669camaro's Avatar
 
Join Date: Feb 2015
Location: Omaha, Ne
Posts: 189
Likes: 0
Received 0 Likes on 0 Posts
Default

I can't tell but are you running a spacer between the flex plate and crank? If not you need to on a 5.3 with an old school tranny.
6669camaro is offline  
Old 03-07-2015, 09:14 PM
  #26  
On The Tree
iTrader: (1)
 
6669camaro's Avatar
 
Join Date: Feb 2015
Location: Omaha, Ne
Posts: 189
Likes: 0
Received 0 Likes on 0 Posts
Default

Here's a link to the spacer that you need if your not running one. You also need longer bolts to go along with that.

http://www.jegs.com/i/JEGS+Performan...FQiNaQod1Z4A-A
6669camaro is offline  
Old 03-07-2015, 09:56 PM
  #27  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

yup thats the issue. i dont have one of those spacers. all i have is stock flexplate bolted to end of crank didnt know i needed spacer in between motor and flexplate. i just thought that hughes adapater made up for the difference.
gsxrred1000 is offline  
Old 03-07-2015, 10:19 PM
  #28  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

So if I'm correct than it should 6.0 crank spacer than 5.3 flexplate than Hughes adapter? I know a 6.0 flexplate and spacer work fine with mounting to a th400 just a little unsure on the 5.3l curved flexplate and what's needed to run it.
gsxrred1000 is offline  
Old 03-07-2015, 10:21 PM
  #29  
On The Tree
iTrader: (1)
 
6669camaro's Avatar
 
Join Date: Feb 2015
Location: Omaha, Ne
Posts: 189
Likes: 0
Received 0 Likes on 0 Posts
Default

Also I had an issue with my j&w bell housing hitting the top 3bolts on the cover that holds the rear main seal. The trans wouldn't pull flush to the engine because of it. Had to change out the bolts and slightly grind the heads of the new ones.
6669camaro is offline  
Old 03-07-2015, 10:24 PM
  #30  
On The Tree
iTrader: (1)
 
6669camaro's Avatar
 
Join Date: Feb 2015
Location: Omaha, Ne
Posts: 189
Likes: 0
Received 0 Likes on 0 Posts
Default

I don't believe the 5.3 flex plate will work. I've had to go with the 6.0 flex plate on the last couple 5.3 swaps I did with old school transmissions.
6669camaro is offline  
Old 03-08-2015, 07:26 AM
  #31  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

The Hughes spacer I have is supposed to adapt a 5.3 curved flexplate to the th400 with no issue. The torque converter I have bolts right to flexplate. Anyone use the Hughes spacer instead up gm spacer?
gsxrred1000 is offline  
Old 03-08-2015, 10:25 AM
  #32  
On The Tree
iTrader: (1)
 
6669camaro's Avatar
 
Join Date: Feb 2015
Location: Omaha, Ne
Posts: 189
Likes: 0
Received 0 Likes on 0 Posts
Default

Gotcha. Not familiar with there spacer. I've always just used the gm spacer and 6.0 flex plate.
6669camaro is offline  
Old 03-11-2015, 11:33 PM
  #33  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

well ill have to pull trans back out then to see whats what with flexplate and all or just swap 6.0 plate and spacer in.

moving on for now tho. one main puzzle piece showed up. custom built s476r turbo with billet wheel.
gsxrred1000 is offline  
Old 03-11-2015, 11:48 PM
  #34  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

Camaro f body 4 corner steam line with water pump tapped for bypass. F body water pump Not sure if this will work but I yanked a air inlet temp sensor and plug with pigtail from one of my gsxr1000 airbox's. siliconed it in ls1 intake.

Last edited by gsxrred1000; 03-12-2015 at 12:01 AM. Reason: wrong pics
gsxrred1000 is offline  
Old 03-12-2015, 10:24 AM
  #35  
On The Tree
 
Join Date: May 2012
Posts: 175
Likes: 0
Received 0 Likes on 0 Posts
Default

Is that the factory steam vent setup? Looks like it ties into all four. Where are you attaching the rubber hose?
turboventura is offline  
Old 03-12-2015, 07:36 PM
  #36  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

Yes all 4 corners and I tapped the top of the water pump and ran hose to it. Beats having to run it to the rad. And all.
gsxrred1000 is offline  
Old 03-12-2015, 09:24 PM
  #37  
Staging Lane
iTrader: (5)
 
spray280's Avatar
 
Join Date: Aug 2014
Location: Harrisonburg
Posts: 91
Likes: 0
Received 0 Likes on 0 Posts
Default

My trans/converter setup was the same way. I used the hughes spacer & flywheel.
The converter snout is a very tight fit in the spacer first time it goes in.
spray280 is offline  
Old 03-12-2015, 09:58 PM
  #38  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by spray280 View Post
My trans/converter setup was the same way. I used the hughes spacer & flywheel.
The converter snout is a very tight fit in the spacer first time it goes in.
Ok good to know. I'm still gonna pull it apart and check it out. Just to make sure I don't have to put shims in between the converter and flexplate. Well see in a week or 2 after I finish up turbo kit. Thanks for letting me know.
gsxrred1000 is offline  
Old 03-16-2015, 09:10 PM
  #39  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

progress report. on to the manifolds and vbands.
gsxrred1000 is offline  
Old 03-16-2015, 09:35 PM
  #40  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 275
Likes: 0
Received 0 Likes on 0 Posts
Default

well this is the worst part of the build so far. 5.3l came with truck pulley and im running corvette alt. bracket and power steering pump.fbody water pump also. so i decided to space out corvette alt. bracket to ther fbody water pump and than all i need is a fbody crank balancer. this is where it gets good. i ordered a fbody balancer from a member on here. received a truck balancer. got a refund. ordered another balancer from another member on here. never shipped it. alot of excuses and a couple threats from me 3 weeks later i get a refund still no balancer tho. i work at a chevy dealer. fbody balancer not available and on backorder. i seen one on amazon new ac delco i ordered it. a week later a corvette balancer shows up and amazon cant tell when they could ship the right one. get a refund from them. now im furious. 2 months and no balancer. i need the balancer in place to build hotside turbo pipe in front of balancer. so finally i see a guy on craigslist an hour away from my house with a bunch of stock fbody parts for sale. he says he pulled the stock balancer off his 99 camaro ls1. this has to be right now. NOPE pulley comes and its a vette pulley. so i decide to go with a vette setup and only need a new tensioner now. well with the vette pulley on the timing cover is tapped with a 90 10an fitting for turbo oil drain and fitting hits pulley. so i decided to do some machining on a brake lathe at work. shaved off lip of pulley where the a/c belt would go. hope this dont throw the balance off. well after installing it i have about and 1/8" between pulley and oil return fitting. it doesnt hit but is damn close. i figure if that crank pulley moves i bigger issues than it hitting the the fitting. so im rolling with it. heres pics of pulley before and after and fitting clearance.

stock vette pulley

shaved off lip on a/c side

machining. lol

little close.

Last edited by gsxrred1000; 03-16-2015 at 09:56 PM. Reason: t
gsxrred1000 is offline  

Thread Tools
Search this Thread
Quick Reply: (Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS


About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: