Notices
Generation III External Engine LS1 | LS6 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories
Sponsored by:
Sponsored by:

Magnaflow fitment sucks! (Pics)

 
Old 01-30-2011, 01:51 AM
  #21  
TECH Fanatic
iTrader: (5)
 
Mumbles's Avatar
 
Join Date: Aug 2007
Location: SouthEastern Iowa
Posts: 1,422
Likes: 0
Received 0 Likes on 0 Posts
Default

We had the same issue when installing the Magnaflow Catback on my friend, Dave'a 98 Z28.

As a remedy to keep the drivers tip level, we installed the hanger that is too long just as it is pictured multiple times above. Then, looking from the rear of the car, we rotated the rubber piece clockwise as far as it would go, until it hits the framerail. This would make the rod attached to the exhaust tip now be in the top hole of the rubber hanger and the factory hanger stud in the lower hole. (I with I had a picture to show you.) Then we used a couple zipties to hold it in place.

This isn't the best solution, but it's held up over the past couple years on Dave's Camaro, so it has proven to serve its purpose.

Again, I'm sorry I don't have a picture to show you exactly what I mean. I hope you can get the idea from my description.

The real solution would be as 01ssreda4 mentioned above. Have the hanger cut and re-bent to fit correctly. Or better yet, bring this to Magnaflow's attention and have them build the $400+ performance part correctly.
Mumbles is offline  
Old 01-30-2011, 10:30 AM
  #22  
Staging Lane
 
firehawk1082's Avatar
 
Join Date: Nov 2008
Posts: 64
Likes: 0
Received 0 Likes on 0 Posts
Default

I have same exhaust and mine fit perfectly , no rubbing and straight. That hanger thats welded to the side pipe is way longer than mine was , thinken you got wrong pipe with the kit
firehawk1082 is offline  
Old 01-30-2011, 11:22 AM
  #23  
Launching!
 
MI-Z/28's Avatar
 
Join Date: Mar 2010
Location: Earth
Posts: 289
Likes: 0
Received 0 Likes on 0 Posts
Default

I had the same issue. I just got out a cut off wheel, tig welder, and some steel rod. Made a couple adjustments and made it work. Simple.

I know it sucks having to do something like that when you pay a good chunk of money for a part that you expect to have top notch quality, but it only took me 15min to fix it myself so I wasn't too concerned about it.
MI-Z/28 is offline  
Old 01-30-2011, 03:51 PM
  #24  
On The Tree
 
Join Date: Jan 2010
Location: Branford CT
Posts: 159
Likes: 0
Received 0 Likes on 0 Posts
Default

Had the same exact problem with my drivers side. Also the part of the tip that connected to the muffler outlet did not have the four cuts on it so it could be tighted to the muffler outlet. The only way i could get the drivers side tip to line up was the rotate the hanger clockwise like Mumbles said and secure it with metal clamp. I am now debating on contacting magnaflow to fix the problem. Do you think their lifetime warentee would cover this?
kb274868123 is offline  
Old 01-30-2011, 08:17 PM
  #25  
On The Tree
iTrader: (3)
 
Join Date: May 2008
Location: Midland,MI
Posts: 107
Likes: 0
Received 0 Likes on 0 Posts
Default

had the same problem on the drivers side when the shop installed mine. I love the sound of my magnaflow but the catback rattles like crazy and i have already broke a weld one of the hangers
Dewman is offline  
Old 01-30-2011, 09:29 PM
  #26  
TECH Fanatic
Thread Starter
iTrader: (8)
 
Latch's Avatar
 
Join Date: Mar 2010
Location: Mechanicsville, VA
Posts: 1,444
Likes: 0
Received 0 Likes on 0 Posts
Default

Alright, today we got it on by doing a little fabricating. We cut the hanger that's too long and then heated it and bent it so now it lines up how it's supposed to. Wasn't entirely difficult but seemed a little absurd to have to hack up a $400 catback that I bought because everyone said it has "good fitment." BS.
Latch is offline  
Old 01-30-2011, 10:07 PM
  #27  
12 Second Club
iTrader: (7)
 
rob69zombie's Avatar
 
Join Date: Feb 2009
Location: Havelock, NC
Posts: 1,138
Likes: 0
Received 0 Likes on 0 Posts
Default

Magnaflow sucks! Sorry you're having issues with it man. I agree about the tips too.
rob69zombie is offline  
Old 01-31-2011, 12:06 AM
  #28  
On The Tree
 
unknown pontiac's Avatar
 
Join Date: Jul 2006
Location: Texas
Posts: 108
Likes: 0
Received 0 Likes on 0 Posts
Default

my cat-back fits perfect ,I was worried about the tips sticking out to much, tucked in to far or not being centered but they are perfect. I'm happy with my kit. all I need now is a cut out.
unknown pontiac is offline  
Old 01-31-2011, 11:38 PM
  #29  
TECH Resident
iTrader: (4)
 
NeedaV8foundation's Avatar
 
Join Date: Feb 2008
Location: Naperville, IL
Posts: 861
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by got-a-ls1 View Post
i had the exact same problem with my magnaflow...... junk if you ask me. i had to heat up and bend the drivers side mount of the tip. never did get it to fit right and the rubber mount right now i actually just have sitting up on the heat shield because it pissed me off so bad.. i wont buy magnaflow again for any of my cars. also i dont know if its the lpp y pipe or the magaflow but i CANNOT get enough length from the i pipe and the y pipe to secure them together good... even with the expensive accuseal clamps.. i have at best 1/4 of an inch for the y pipe and i pipe of the magnaflow. not happy with the fitment but everyone loves the sound.. i dont know how this **** cat back gets such a good rep for fitment. not even close...
im in your boat, my magnaflow broke (welds) after only 3000 miles. i was on the phone for a few hours between my shop i got it from and magnaflow, they wanted me to buy a new kit, pay for shipping for my new one, pay for shipping on my old one to cali, and then they would refund me for the new kit i bought but not shipping..... will never buy another magnaflow
NeedaV8foundation is offline  
Old 02-01-2011, 12:37 AM
  #30  
TECH Senior Member
iTrader: (96)
 
01ssreda4's Avatar
 
Join Date: Aug 2007
Location: Turnin' Wrenches Infractions: 005
Posts: 24,221
Likes: 0
Received 0 Likes on 0 Posts
Default

Funny how all this comes to light when magnaflow has had what seems to be a stellar record up until now.
01ssreda4 is offline  
Old 02-01-2011, 08:24 AM
  #31  
TECH Regular
iTrader: (4)
 
Join Date: Jul 2009
Posts: 494
Likes: 0
Received 0 Likes on 0 Posts
Default

Are these fitment problems with the single tip ("cannon" tip) style? Anyone with the quad tip have these issues? Like I said, my quad tip Magnaflow fit, looks, installed perfectly. No rattles, as of yet anyway. Was I just lucky? I say get magnaflow cust. service on this, esp since you are upset about paying $XX it should'nt be like this- AND RIGHTFULLY SO! You didn't get a reduced price for a sub standard system, you bought new so...
pewter2002 is offline  
Old 02-01-2011, 10:01 AM
  #32  
FormerVendor
iTrader: (45)
 
Frost's Avatar
 
Join Date: Jul 2005
Location: Richmond VA
Posts: 5,913
Likes: 0
Received 0 Likes on 0 Posts
Default

A friend and I just put this catback on my wife's TA. It fit awesome.... It took about a half hour to get it installed and lined up properly. All of the mounts went where they should have and the tips exited where they should have as well.

These pics kind of suck but they've been on my fone for a few weeks. Will see if I can get a pic of that driver's side for you on top.








Attached Thumbnails Magnaflow fitment sucks! (Pics)-1.jpg   Magnaflow fitment sucks! (Pics)-2.jpg   Magnaflow fitment sucks! (Pics)-3.jpg  
Frost is offline  
Old 02-01-2011, 11:22 AM
  #33  
TECH Regular
iTrader: (2)
 
Join Date: Jan 2011
Posts: 481
Likes: 0
Received 0 Likes on 0 Posts
Default

Did you email these pics to Magnaflow and get their opinion?
OldCobraGuy is offline  
Old 02-01-2011, 11:44 AM
  #34  
12 Second Club
iTrader: (10)
 
disc0monkey's Avatar
 
Join Date: Jan 2009
Location: 5.0
Posts: 1,302
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by MI-Z/28 View Post
I had the same issue. I just got out a cut off wheel, tig welder, and some steel rod. Made a couple adjustments and made it work. Simple.

I know it sucks having to do something like that when you pay a good chunk of money for a part that you expect to have top notch quality, but it only took me 15min to fix it myself so I wasn't too concerned about it.
just do this and its perfect. chances are your going to get close out of the box but will have to bend or move the hangers to get it right. i was a welder at a performance garage, we rarely ever just hung on a catback.

Last edited by disc0monkey; 02-01-2011 at 12:05 PM.
disc0monkey is offline  
Old 02-01-2011, 12:09 PM
  #35  
TECH Fanatic
iTrader: (44)
 
Undertow74's Avatar
 
Join Date: Oct 2007
Location: Califonia
Posts: 1,205
Likes: 0
Received 0 Likes on 0 Posts
Default

interesting, Mine went on fine without a problem. I totally understand your frustration, cus i hate when im installing things and it isnt going right. But its kind of harsh to say its complete garbage when it is a really decent cat back. They do make these units to fit the 98-02 firebirds, but just like everything in life, its imposible to be 100% All of the time.
Undertow74 is offline  
Old 02-02-2011, 10:53 AM
  #36  
FormerVendor
iTrader: (45)
 
Frost's Avatar
 
Join Date: Jul 2005
Location: Richmond VA
Posts: 5,913
Likes: 0
Received 0 Likes on 0 Posts
Default

Here is a better pic on her driver's side.


-edit-
Looking at your first post, it looks like if you would mount your tip hanger then it would push your existing rubber mount out to the side as it did below for us... which is fine.

Attached Thumbnails Magnaflow fitment sucks! (Pics)-mgnflow.jpg  
Frost is offline  
Old 02-02-2011, 11:28 AM
  #37  
TECH Senior Member
iTrader: (96)
 
01ssreda4's Avatar
 
Join Date: Aug 2007
Location: Turnin' Wrenches Infractions: 005
Posts: 24,221
Likes: 0
Received 0 Likes on 0 Posts
Default

Where are yall getting these black tailpipe hangers? The ones that bolt to the car? I have seen this before but I only have the stockers to mount my tips. I wonder if they will work?
01ssreda4 is offline  
Old 02-02-2011, 11:33 AM
  #38  
FormerVendor
iTrader: (45)
 
Frost's Avatar
 
Join Date: Jul 2005
Location: Richmond VA
Posts: 5,913
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by 01ssreda4 View Post
Where are yall getting these black tailpipe hangers? The ones that bolt to the car? I have seen this before but I only have the stockers to mount my tips. I wonder if they will work?
The black 'bar style' mounts come with the catback and so does their hardware.
Frost is offline  
Old 02-02-2011, 11:39 AM
  #39  
TECH Senior Member
iTrader: (96)
 
01ssreda4's Avatar
 
Join Date: Aug 2007
Location: Turnin' Wrenches Infractions: 005
Posts: 24,221
Likes: 0
Received 0 Likes on 0 Posts
Default

Yeah i kinda figured that bc I have seen those on other Magnaflow systems. They seem to be a real pain in the *** bc the bolts didnt line up with the holes in the frame very good. Guess I will have to modify the stockers to make them work.
01ssreda4 is offline  
Old 02-02-2011, 11:44 AM
  #40  
FormerVendor
iTrader: (45)
 
Frost's Avatar
 
Join Date: Jul 2005
Location: Richmond VA
Posts: 5,913
Likes: 0
Received 0 Likes on 0 Posts
Default

Seems like one of them was a little tight, but it was such an easy fix that it has slipped out of mind...
Frost is offline  

Thread Tools
Search this Thread
Quick Reply: Magnaflow fitment sucks! (Pics)


About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: