Conan steam pipe routing - LS1TECH



Generation III External Engine LS1 | LS6 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories
Sponsored by:
Sponsored by:

Conan steam pipe routing

Reply
 
Thread Tools Search this Thread
Old 08-30-2014, 03:06 PM   #1
11 Second Club
Thread Starter
iTrader: (24)
 
97ss497's Avatar
 
Join Date: Sep 2007
Location: Northern Ill
Posts: 250
Default Conan steam pipe routing

Installed conan's stuff he referred me to; the pipe in the back is GM part #12605716. The front steam vent is an LS6 tube. The 3 tube fitting is here:

http://www.chicompany.net/index.php?...68a08e042e8a7e

I've got to add clamps yet; should be a real nice looking setup and functional too.

Much appreciated conan!











97ss497 is offline   Reply With Quote
Old 08-30-2014, 07:23 PM   #2
That's MISTER MODERATOR
iTrader: (9)
 
Paul Bell's Avatar
 
Join Date: Nov 2005
Location: NYC
Posts: 7,330
Default

Lookin good!
Paul Bell is offline   Reply With Quote
Old 08-30-2014, 09:52 PM   #3
TECH Senior Member
iTrader: (5)
 
conan's Avatar
 
Join Date: May 2004
Location: 7,000ft
Posts: 6,394
Default



Engine looks bad ***, liking the intake. Glad I could help out with the steam vent plumbing.
conan is offline   Reply With Quote
Old 08-31-2014, 12:55 AM   #4
TECH Addict
iTrader: (57)
 
99'CajunFirehawk157's Avatar
 
Join Date: Jun 2007
Location: USA
Posts: 2,702
Thumbs up

I did something very similar, note the black rubber hose at the bottom of the pic by the power steering reservoir going into a "T"...BTW who did your hydro?
Attached Thumbnails
Conan steam pipe routing-img_0455.jpg  
99'CajunFirehawk157 is offline   Reply With Quote
Old 08-31-2014, 07:23 AM   #5
11 Second Club
Thread Starter
iTrader: (24)
 
97ss497's Avatar
 
Join Date: Sep 2007
Location: Northern Ill
Posts: 250
Default

Quote:
Originally Posted by 99'CajunFirehawk157 View Post
I did something very similar, note the black rubber hose at the bottom of the pic by the power steering reservoir going into a "T"...BTW who did your hydro?
Pat from Baytown Texas, he does great work.

Your engine compartment looks sick!
97ss497 is offline   Reply With Quote
Old 08-31-2014, 01:12 PM   #6
TECH Senior Member
iTrader: (5)
 
conan's Avatar
 
Join Date: May 2004
Location: 7,000ft
Posts: 6,394
Default

Make sure to have the rear hose on and clamped before you put the engine back in the car. I forgot how tight it was back there and had to pull the intake manifold off to hook up the rear hose
conan is offline   Reply With Quote
Old 08-31-2014, 08:34 PM   #7
11 Second Club
Thread Starter
iTrader: (24)
 
97ss497's Avatar
 
Join Date: Sep 2007
Location: Northern Ill
Posts: 250
Default

Quote:
Originally Posted by conan View Post
Make sure to have the rear hose on and clamped before you put the engine back in the car. I forgot how tight it was back there and had to pull the intake manifold off to hook up the rear hose
This motor is going in my 70 Camaro, lots more room then a 4th gen :-). Plus I have the whole front clip off.
97ss497 is offline   Reply With Quote
Old 09-01-2014, 07:59 AM   #8
TECH Senior Member
iTrader: (5)
 
conan's Avatar
 
Join Date: May 2004
Location: 7,000ft
Posts: 6,394
Default

Quote:
Originally Posted by 97ss497 View Post
This motor is going in my 70 Camaro, lots more room then a 4th gen :-). Plus I have the whole front clip off.
Cheater
conan is offline   Reply With Quote
Old 03-13-2017, 07:29 AM   #9
TECH Resident
iTrader: (12)
 
BennyB's Avatar
 
Join Date: Sep 2005
Location: Omaha, NE
Posts: 934
Default

Figured I'd bump this thread bc I wanted to know if anyone has tried this with a fast 102 intake manifold and whether or not it works?
BennyB is offline   Reply With Quote
Old 03-13-2017, 03:15 PM   #10
That's MISTER MODERATOR
iTrader: (9)
 
Paul Bell's Avatar
 
Join Date: Nov 2005
Location: NYC
Posts: 7,330
Default

I can't imagine why these lines would not work.
Paul Bell is offline   Reply With Quote
Old 03-15-2017, 01:43 PM   #11
TECH Senior Member
iTrader: (5)
 
conan's Avatar
 
Join Date: May 2004
Location: 7,000ft
Posts: 6,394
Default

Quote:
Originally Posted by BennyB View Post
Figured I'd bump this thread bc I wanted to know if anyone has tried this with a fast 102 intake manifold and whether or not it works?
Do you have the fast 102 on you car currently ?
conan is offline   Reply With Quote
Old 03-15-2017, 11:55 PM   #12
TECH Resident
iTrader: (12)
 
BennyB's Avatar
 
Join Date: Sep 2005
Location: Omaha, NE
Posts: 934
Default

Quote:
Originally Posted by conan View Post
Do you have the fast 102 on you car currently ?
It will whenever Maryland Speed gets it shipped
BennyB is offline   Reply With Quote
Old 03-16-2017, 02:57 PM   #13
TECH Senior Member
iTrader: (5)
 
conan's Avatar
 
Join Date: May 2004
Location: 7,000ft
Posts: 6,394
Default

The rear pipe should fit fine with it going on the out side of the oil pressure sending unit. I haven't heard of the crossover pipe in the front hitting the fast intakes so you shoud be fine there too.

What coolant pipes are you running currently ?
conan is offline   Reply With Quote
Old 03-17-2017, 01:47 AM   #14
TECH Resident
iTrader: (12)
 
BennyB's Avatar
 
Join Date: Sep 2005
Location: Omaha, NE
Posts: 934
Default

Quote:
Originally Posted by conan View Post
The rear pipe should fit fine with it going on the out side of the oil pressure sending unit. I haven't heard of the crossover pipe in the front hitting the fast intakes so you shoud be fine there too.

What coolant pipes are you running currently ?
Ok sounds good and thanks for your input. I'll be using the stock LS1/6 front coolant pipe and in the rear I'll be using the 12605716 pipe that's pictured in this thread.
BennyB is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2007 4.8 intake manifold port question 97ss497 Generation III External Engine 2 02-27-2017 08:23 PM
1990 ws6 gta 97ss497 Vehicle Classifieds 15 11-17-2016 06:36 PM
99 Hugger makes GMHTP mag 97ss497 Midwestern Members 2 12-14-2013 08:05 PM
1999 Hugger Orange Z28 97ss497 Vehicle Classifieds 35 09-11-2013 11:52 AM
Bogart RT's installed! 97ss497 Wheels & Tires 28 04-19-2012 09:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:56 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send