Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Conversions & Hybrids
Sign in using an external account
Register Forgot Password?
Register iTraderTimeslips Photos Members Search Today's Posts Mark Forums Read Used CarsVendor Directory
Search

Conversions & Hybrids
LSX Engines in Non-LSX Vehicles
Sponsored by
Don Hardy Race Cars

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 04-03-2010, 10:37 AM   #1
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default dbw not working help please

I have a 01 5.3 and 03 pedal and tac module. The motor will fire up and idle fine without the module and pedal hooked up, but with them hooked up it wont start the fuel pump relay clicks rapidly when you turn the key on. also the scanner wont communicate. with the module unhooked i was able to get these codes

[PCM] P1120 - Throttle Position (TP) Sensor 1 Circuit (SES) (History) (Immature)
[PCM] P1220 - Throttle Position (TP) Sensor 2 Circuit (SES) (History) (Immature)
[PCM] P1221 - Fuel Pump Secondary Circuit Low (SES) (History) (Immature)
[PCM] P1275 - Accelerator Pedal Position (APP) Sensor 1 Circuit (History) (Immature)
[PCM] P1280 - Accelerator Pedal Position (APP) Sensor 2 Circuit (History) (Immature)
[PCM] P1516 - Throttle Actuator Control (TAC) Module Throttle Actuator Position Performance (SES) (History) (Immature)
[PCM] P1518 - Electronic Throttle Module to PCM Communication (SES) (Pending) (Old) (History) (Current) (Immature)
[PCM] P1571 - Traction Control Torque Request Circuit (Old) (History) (Current) (Immature)
lrazer is offline   Reply With Quote
Old 04-04-2010, 08:03 AM   #2
TECH Veteran
Garage is empty, add now
 
Old Geezer's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: GA, USA
Posts: 4,162
Send a message via AIM to Old Geezer
Default

What yr is the PCM??
__________________
Chuck
Hot rodding and drag racing since 55
Injector inspector
55 Chevy/LQ9 Tyr Fryer
Turbo Buick in the 9's/142mph.
Old Geezer is offline   Reply With Quote
Old 04-04-2010, 12:34 PM   #3
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

The pcm, harness, throttlebody, and engine are all 01. The pedal and tac module are 03.
I read this on another board:
Quote:
Originally Posted by Bo185 View Post
Make sure they are the correct pedal and TAC box for the application. That might be part of the problem.

TAC module has two connections, one for the pedal harness..other hooks into main engine harness this is all you need it should have the 9-pin connector the later ones are 6-pin.

TAC modules have to match up to the year range of the PCM AND the throttle body.

03-05 TAC module works with 03-05 truck TB and 03-05 PCM (BLUE/GREEN connectors)

01-02 TAC module works with 01-02 truck TB, 97-04 Vette TB, and 01-02 PCM (BLUE/RED connectors).

03-05 TAC modules have an aluminum mounting base, 01-02 TAC modules are all black plastic including the mounting base.
So this seems to be my problem, is this correct?

Last edited by lrazer; 04-04-2010 at 01:01 PM..
lrazer is offline   Reply With Quote
Old 04-04-2010, 05:20 PM   #4
Banned
Garage is empty, add now
 
Trader Rating: 43
Join Date: Aug 2008
Location: Northeast PA
Posts: 1,066
Default

Quote:
Originally Posted by lrazer View Post
The pcm, harness, throttlebody, and engine are all 01. The pedal and tac module are 03.
I read this on another board:


So this seems to be my problem, is this correct?
Go here
http://www.chevythunder.com/
Leonard has a good explanation of DBW parts and interchanges with pictures to help you identify the parts
poconojoe is offline   Reply With Quote
Old 04-05-2010, 12:19 PM   #5
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

seems like i need an 03 throttle body but the 01 pcm supposidly should work
lrazer is offline   Reply With Quote
Old 04-05-2010, 07:39 PM   #6
Launching!
Garage is empty, add now
 
pdsq98gt's Avatar
 
Trader Rating: 0
Join Date: Sep 2007
Location: Kansas City, MO
Posts: 289
Default

That 01 truck pcm most likely won't be able to control the tac. Is the harness pinned for dbw?
pdsq98gt is offline   Reply With Quote
Old 04-05-2010, 08:42 PM   #7
Banned
Garage is empty, add now
 
Trader Rating: 43
Join Date: Aug 2008
Location: Northeast PA
Posts: 1,066
Default

Quote:
Originally Posted by pdsq98gt View Post
That 01 truck pcm most likely won't be able to control the tac. Is the harness pinned for dbw?
If it has a DBW OS in it, it will since in 2001 and 2002 they used the same 12200411 PCM for both DBC and DBW applications
poconojoe is offline   Reply With Quote
Old 04-06-2010, 11:35 PM   #8
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

the motor was dbw
lrazer is offline   Reply With Quote
Old 04-06-2010, 11:39 PM   #9
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

so i got the throttle body that goes with the tac but its the 8 pin single connector, i assume i need to get the connector and just wire the 2 and 6 wire connectors to it?
lrazer is offline   Reply With Quote
Old 04-07-2010, 05:09 AM   #10
Banned
Garage is empty, add now
 
Trader Rating: 43
Join Date: Aug 2008
Location: Northeast PA
Posts: 1,066
Default

Quote:
Originally Posted by lrazer View Post
so i got the throttle body that goes with the tac but its the 8 pin single connector, i assume i need to get the connector and just wire the 2 and 6 wire connectors to it?
You can make it work but IIRC you need to switch 2 of the wires. By the way 2001 didn't use the single plug throttlebody
poconojoe is offline   Reply With Quote
Old 04-07-2010, 08:58 AM   #11
Formerly 99-2door-08/30/2010
Garage is empty, add now
 
PitchblackC3's Avatar
 
Trader Rating: 3
Join Date: Apr 2007
Location: Broken Bow, OK
Posts: 170
Default

You can NOT run a 2003 throttle body and TAC on a 2001 PCM.
Trust me, I tried it.
When I got my C3 the stock 2001 DBW throttle body was damaged and it was impossible to find a 2001 DBW throttle body. (now of course they are all over ebay, and cheap!). I put a 2003 Throttle body and TAC in my truck and ran it that way for a while. Everything worked great unless you pressed the pedal to 80% or more. It would immediately trigger reduced power mode (engine running or not), and the ignition would have to be turned off for about 2 minutes to reset it. The 2001 PCM and 2003 TAC are incompatible, they will not communicate correctly.
I solved the problem by repinning my harness and running a 2003 PCM as well. Works great, but I do get BCM codes when I put on my scanner. Also I never got the PCM to correctly activate the AC clutch. I figured I would wire it straight to the switch if summer came and I hadn't figured it out, but now I am going a different route.
Today I am switching everything back over to 2001 PCM, TAC and pinning the harness back the way it was. I am putting on a TBSS intake and 90mm throttle body which will work with the 2001 TAC without an adapter module.

Side note, my 2001 accel pedal works successfully with both 2001 and 2003 TAC/PCM.
PitchblackC3 is offline   Reply With Quote
Old 04-07-2010, 10:24 AM   #12
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

would that be something that could be tuned out. this is in a less than stock application...
Click the image to open in full size.
lrazer is offline   Reply With Quote
Old 04-07-2010, 10:27 AM   #13
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

Quote:
Originally Posted by 99-2door View Post
Side note, my 2001 accel pedal works successfully with both 2001 and 2003 TAC/PCM.
so my 03 pedal may work with 01 tac
maybe i just need to find someone who wants to trade tac's
lrazer is offline   Reply With Quote
Old 04-07-2010, 08:19 PM   #14
Formerly 99-2door-08/30/2010
Garage is empty, add now
 
PitchblackC3's Avatar
 
Trader Rating: 3
Join Date: Apr 2007
Location: Broken Bow, OK
Posts: 170
Default

There is nothing you can do with the tune. The problem lies in the difference in serial protocol between the 2 years.

The AC problem could perhaps be fixed with the tune, but as of now the software doesn't have that option.
PitchblackC3 is offline   Reply With Quote
Old 04-08-2010, 01:13 AM   #15
Teching In
Garage is empty, add now
 
lrazer's Avatar
 
Trader Rating: 0
Join Date: Jan 2010
Posts: 19
Default

im not running ac anyway so thats not an issue its just this dbw stuff holding me up
lrazer is offline   Reply With Quote
Old 04-25-2010, 10:00 PM   #16
Launching!
Garage is empty, add now
 
LS88FoxBody's Avatar
 
Trader Rating: 2
Join Date: Jan 2010
Location: Demotte , IN
Posts: 289
Send a message via AIM to LS88FoxBody
Default

http://www.ls1tech.com/forums/conver...lp-please.html

http://www.ls1tech.com/forums/12915568-post134.html
LS88FoxBody is offline   Reply With Quote
Old 01-06-2012, 04:44 PM   #17
Teching In
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jan 2012
Posts: 1
Default

I am having the same problem. Did you find a solution?
5.3fj60 is offline   Reply With Quote
Old 01-30-2013, 07:19 AM   #18
Registered User
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jan 2013
Posts: 4
Default

Anybody find the answer to this
Jcarlisle is offline   Reply With Quote
Old 01-30-2013, 08:55 AM   #19
LS1Tech Sponsor
Garage is empty, add now
 
BP Automotive's Avatar
 
Trader Rating: 1
Join Date: Oct 2012
Location: Columbia, Kentucky
Posts: 539
Default

as stated above, the second generation drive by wire(03-07ish) will not work with the first generaton DBW PCMs. That was his issue.

It is always best to try and get all of the parts from the same vehicle if possible. However, the pedals are all interchangeable.

Most generally, all of the 03-07 stuff should work together. I have seen times when it did not. Its really a crapshoot unless you get them all from the same year. (ideal if not from same vehicle.)
__________________
LSX, LTX Stand alone harnessing. S10 LSX conversion PLUG AND PLAY harnesses, 24x conversion PLUG AND PLAY harnesses. LT1 to LSX PLUG AND PLAY Harnesses. Factory harness Rewire.
"EFI Simplified!"
bpautomotive@live.com
www.bp-automotive.com
http://stores.ebay.com/BP-Automotive-and-Wiring
BP Automotive is online now   Reply With Quote
Old 01-30-2013, 08:05 PM   #20
Registered User
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jan 2013
Posts: 4
Default Dbw

My motor, pedal and module all came from same vehicle to my knowledge. I do know for sure that my motor,ecu came from 2002 tahoe. Salvage yard sent me later on a DBW module and pedal. My module is all plastic and my pedal is all metal except APP SENSOR is obviously plastic. With TAC MODULE connected engine will not start, data port(aldl) goes out and fuel pump relay clicks rapidly. At this point I have verified that TAC module is getting 12v , all wires are correct and not broken or melted together. APP sensor is functioning properly in their suggested ranges. If I apply pedal down nothing happens at the throttle body. If TAC module is unplugged then engine cranks, runs and then idles up because TAC MODULE is unplugged. Any suggestions would be greatly appreciated. Sorry for hi jacking someone else's thread but I am hoping someone can help and if someone else read this maybe it will save them the trouble that I have been dealing with. Thanks
Jcarlisle is offline   Reply With Quote
Old 01-30-2013, 08:05 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
2002, body, circuit, communication, dbw, ebay, electronic, module, p1120, p1518, pcm, position, sensor, tac, throttle, tp, truck, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 12:41 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details