Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Conversions & Hybrids
Sign in using an external account
Register Forgot Password?
Search

Conversions & Hybrids
LSX Engines in Non-LSX Vehicles
Sponsored by
Don Hardy Race Cars

Update on my 87 Camaro 5.3 build

Reply
 
Thread Tools Search this Thread
Old 04-14-2008, 06:53 PM   #1
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default Update on my 87 Camaro 5.3 build

I finally got some picture up on my updates of my build. In these pics you will see the 5.3 in my car with the truck manifold and truck harness with fuse box. Let me know what you think. Any tips or advise would be accepted as well. Questions are welcomed as well. If anyone can get me some pics on y-pipe routing with a 4L60e it will be greatly appreciated. Thanks for everyones help!








1987earthquake is offline   Reply With Quote
Old 04-15-2008, 09:36 AM   #2
LS1TECH Sponsor
1965 Chevrolet Chevelle
 
Trader Rating: 5
Join Date: Sep 2007
Location: Moline, ILLINOIS
Posts: 645
Default

What mounts did you use?
Carshopinc.com is offline   Reply With Quote
Old 04-15-2008, 11:17 AM   #3
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

Quote:
Originally Posted by Carshopinc.com View Post
What mounts did you use?
The ones that are on there now are some plates I made a while back. This is not the finished stage on mounting. Waiting for you to let me see some pics of how your 1" setback plates look in comparison with the oil pan and firewall. In my opinion the ones on it now set the engine to far to the front. I want to be able to use the stock driveshaft. You told me you would set it up in a third gen you had there so I'm still waiting on that. Everything else as far as the engine goes is ready to go.
1987earthquake is offline   Reply With Quote
Old 04-15-2008, 01:53 PM   #4
LS1TECH Sponsor
1965 Chevrolet Chevelle
 
Trader Rating: 5
Join Date: Sep 2007
Location: Moline, ILLINOIS
Posts: 645
Default

Okay, just checking...... The bad part is my car has Some "other mounts" in it already That I need to pull
Carshopinc.com is offline   Reply With Quote
Old 04-15-2008, 03:12 PM   #5
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

Quote:
Originally Posted by Carshopinc.com View Post
Okay, just checking...... The bad part is my car has Some "other mounts" in it already That I need to pull
I will be heading to work on it again in about 2 1/2 weeks. So Hopefully I can get the mount plates figured out by then. It would be great cause I won't have internet for bout a month then. So only can get on every once in a while then.
Thanks
1987earthquake is offline   Reply With Quote
Old 04-15-2008, 06:06 PM   #6
TECH Apprentice
Garage is empty, add now
 
SheldonZ28's Avatar
 
Trader Rating: 4
Join Date: Jan 2007
Location: Ontario, Canada
Posts: 333
Send a message via AIM to SheldonZ28 Send a message via MSN to SheldonZ28
Default

Quote:
Originally Posted by 1987earthquake View Post
I will be heading to work on it again in about 2 1/2 weeks. So Hopefully I can get the mount plates figured out by then. It would be great cause I won't have internet for bout a month then. So only can get on every once in a while then.
Thanks
Hey, Check out the mounts i did for mine in my build thread on TGO, i just made straps and welded it directly to the k-member as im figuring if i ever need to change my mounts, ill be going to a tubular k-member.

I cut the 6 bolts that hold the stock mounts on, then just dropped the motor in where i wanted then tacked them. ive got .5" of clearance between the f-body pan and the k-member then, since im using a early 4l60e with the same dimentions as a 700R4, ive got my mouting bolt for the trans mount in the exact stock position, so im happy!

Let me know if you would be interested in me fabricating for you the same U straps.

Sheldon
__________________
1989 IROC-Z || T-tops || 5.3L LM7 || 3.73 7.625" Disc || Bright Rally Red ||

All work done by a broke 17 Year old!

http://i105.photobucket.com/albums/m...LS1techsig.jpg
SheldonZ28 is offline   Reply With Quote
Old 04-15-2008, 11:31 PM   #7
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

Quote:
Originally Posted by SheldonZ28 View Post
Hey, Check out the mounts i did for mine in my build thread on TGO, i just made straps and welded it directly to the k-member as im figuring if i ever need to change my mounts, ill be going to a tubular k-member.

I cut the 6 bolts that hold the stock mounts on, then just dropped the motor in where i wanted then tacked them. ive got .5" of clearance between the f-body pan and the k-member then, since im using a early 4l60e with the same dimentions as a 700R4, ive got my mouting bolt for the trans mount in the exact stock position, so im happy!

Let me know if you would be interested in me fabricating for you the same U straps.

Sheldon
I saw it today when I got on there. really don't want to weld any in.. That's my biggest drawback to that..
1987earthquake is offline   Reply With Quote
Old 04-16-2008, 08:37 PM   #8
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

I see a lot of people visit this thread.... Not many replies.. Let me know what you guys think. I know it's not a $25K project. People with budget builds like mine don't really get much support around here. We want to know what everyone thinks about our rides too. A lot of people run from doing swaps like this because of this. Some of you guys that have built fabulous rides out there get all the support and more. It's like we're left out. I know there are others out there who try to build a budget swap car. So give me your thoughts.
1987earthquake is offline   Reply With Quote
Old 04-16-2008, 09:07 PM   #9
TECH Fanatic
Garage is empty, add now
 
V8Rumble's Avatar
 
Trader Rating: 9
Join Date: Aug 2007
Location: Rocky Mtn thin air & snow...
Posts: 1,230
Default

Seems pretty cool to me!

You're definitely a bit further along than I am, but by this weekend I should be able to have the old drivetrain out (it's actually ready to pull right now, but my genius buddy forgot to bring the chain along with the cherry picker... ), and then within a week or two later, I should have the new engine/tranny here...

Keep on it man, even though some of us might not have a whole lot to say, we're still following your progress...!
__________________

Shown on p. 51 of August 2009 "Popular Hot Rodding" magazine.
Thinking of swapping an LS engine? Take a couple minutes to read the LESSONS LEARNED swap thread...
Quote:
Originally Posted by BigEd_72455 View Post
There are 3 ways to learn about doing something wrong man.....

The right way, the wrong way, and the "WHAT THE **** WAS I THINKING OF WHEN I DID THAT S**T!?!?!?" way.
V8Rumble is offline   Reply With Quote
Old 04-16-2008, 09:10 PM   #10
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

Preciate the reply. Keep em comin. I'll be workin on mine in about another 2 weeks. Being in school limits my time to work on it since its 3 1/2 hours away from me. Can't wait to get back on mine. Supposed to get a 2800 stall this comin weekend. Supposed to pick up a trans when I make it home. Trans is not built just a used truck trans. Plan on building one soon tho.

Last edited by 1987earthquake; 04-16-2008 at 09:22 PM..
1987earthquake is offline   Reply With Quote
Old 04-22-2008, 12:49 PM   #11
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

still waiting on some pics from carshopinc... It would be great if I could get some before I head home next week. even measurements would be good. Basically just need verification on whether 1" setback plates will work without me having to cut my k-member and not having to extend driveshaft.
1987earthquake is offline   Reply With Quote
Old 04-22-2008, 07:50 PM   #12
Banned
Garage is empty, add now
 
Trader Rating: 0
Join Date: Nov 2007
Posts: 37
Default

that thing is going to be nasty and rare, but how long have you been working on it for bro
SideWayzta is offline   Reply With Quote
Old 04-22-2008, 10:49 PM   #13
Teching In
Garage is empty, add now
 
Trader Rating: 0
Join Date: Aug 2007
Posts: 30
Default

well, i ditched the 305 for a 350 TPI in my 88 trans am, even though that is barely an upgrade and was more hassle than it was worth, i planned on putting a 5.3 like many have done or maybe an and ls1 but sold it recently
bay_kid26 is offline   Reply With Quote
Old 04-22-2008, 10:53 PM   #14
Launching!
Garage is empty, add now
 
1987earthquake's Avatar
 
Trader Rating: 9
Join Date: May 2007
Location: Hattiesburg, MS
Posts: 215
Default

Quote:
Originally Posted by SideWayzta View Post
that thing is going to be nasty and rare, but how long have you been working on it for bro
I've had the car for going on 2 years now. I first built a tpi 355 with a 700r4 behind it. That didn't take long for me to blow up.... Spun the #2 bearing shattered the rod, destroyed the crank, #1 and 2 rod and piston. parted engine and trans out sold it off. That was about a year ago.. Last summer I began looking into doing an ls1. Found a sweet deal on a 1999 z71 that had been rolled in a ditch. Bought it started tearing it apart. So I guess you can say I've been working on this for about 10 months now. I haven't had much time to work on it being in school tho. So I have to work on it when I go home. I'm about 3 hrs away from it. I hope to be able to drive it in about 3 weeks give or take. Thanks for checkin it out.
1987earthquake is offline   Reply With Quote
Old 04-22-2008, 10:53 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
53, 87, build, camaro


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 12:54 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details