View Full Version : Idling too low?


00TAM6
01-07-2010, 10:01 AM
What does it mean when I start my car some times and my car is idling way too low? Like to the point where it's about to stall? Like at around 500 rpms. Can it be my maf sensor?

RPM WS6
01-07-2010, 10:10 AM
You mean 500rpm on a cold motor/cold weather start?

Normal/factory set idle rpm (once running and warm) is 800rpm for the M6 cars.

Are you sure it's not just the gage? Or you can clearly tell by the sound of the motor?

00TAM6
01-07-2010, 12:47 PM
yeah 500. not a cold start because i drove it then parked it for like 10 min then started it again. i can clrearly tell that it was idling too low by the sound of the engine.

RPM WS6
01-07-2010, 01:21 PM
I'm sure you would have mentioned if you had an SES light, but even if you don't see the light you might have a pending code. Do you have access to a scanner? I'd start by checking for pending codes, or DTCs that don't trip a MIL (Type C).

Anything else would just be guessing. But an MAF related issue might be a good guess as I see you have a K&N. Those filters tend to coat the MAF wires with oil and cause poor readings leading to driveability issues. So if I didn't have a scanner, the first stuff I'd check is all the connections from the air lid to the throttle body (make sure nothing is cracked and no clamp is lose), then I'd clean the MAF wires (you can use an MAF cleaner spray, or do it my way which is rubbing alcohol and Q-tips).

00TAM6
01-07-2010, 01:47 PM
thanks bro. imma try that. but yeah i dont have an ses light on. the first time my car did that was a while ago. i took the k&n out n put a regular fram in ther. seemed to be fine. its prolly my maf cus of that stupid k&n.

Juicy J
01-07-2010, 01:54 PM
As RPM said, try the MAF cleaner. The stuff is cheap, and you can find it at any autoparts store. For whatever reason, my MAF gets dirty pretty quick. I clean every 4-5months. If I don't, my car will have idleing issues.

It could also have to do with your TPS, but I figure it would be throwing a code if something was wrong with it.

transam5.7lt1
01-09-2010, 12:01 AM
Maybe somebody installed an aftermarket cam in your car overnight???? J/K You better check the SES light and post the codes.

RPM WS6
01-09-2010, 11:01 AM
but yeah i dont have an ses light on.

You better check the SES light and post the codes.

:lol:

00TAM6
01-10-2010, 01:38 PM
thanks for all the help. i took out my maf and sprayed it with maf cleaner. my car is idling at the correct rpm now and it feels more responsive. im never putting a stupid k&n airfilter in my car again, it does nothing but puts dirt n oil all over my maf.