Go Back  LS1TECH - Camaro and Firebird Forum Discussion > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Forced Induction
Reload this Page >

(Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS

Notices
Forced Induction Superchargers | Turbochargers | Intercoolers

(Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS

 
Old 09-25-2016, 05:31 AM
  #81  
TECH Enthusiast
iTrader: (3)
 
Nismo Kid's Avatar
 
Join Date: Dec 2010
Location: San Antonio TX
Posts: 636
Likes: 0
Received 0 Likes on 0 Posts
Default

Cool build. What was your 60ft looking like on that 10.11 pass? That 1 more click will likely get the car to achieve your 9 sec goal.
Nismo Kid is offline  
Old 09-25-2016, 08:45 PM
  #82  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default

Upgrading for matts track rental day. Gen 4 rods flat top Pistons and 799 heads. Headgaskets were toast. But no bent rods like I expected to see.
Attached Thumbnails (Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS-img_0077.jpg   (Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS-img_0074.jpg   (Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS-img_0087.jpg   (Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS-img_0095.jpg  
gsxrred1000 is offline  
Old 09-25-2016, 10:28 PM
  #83  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,864
Received 1 Like on 1 Post
Default

pushing water but didnt bend the rods, damn I need your tuning skills
truckdoug is online now  
Old 09-26-2016, 07:07 AM
  #84  
TECH Fanatic
 
svslow's Avatar
 
Join Date: Oct 2015
Location: Royal Oak, MI
Posts: 1,239
Likes: 0
Received 0 Likes on 0 Posts
Default

Which gaskets were you using?
svslow is offline  
Old 10-15-2016, 06:45 AM
  #85  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by svslow View Post
Which gaskets were you using?
Shitty fiber ones. Lol.
gsxrred1000 is offline  
Old 10-15-2016, 09:19 PM
  #86  
11 Second Club
iTrader: (2)
 
Join Date: May 2011
Posts: 413
Likes: 0
Received 0 Likes on 0 Posts
Default

Outstanding build and results! Are you still running 4:10 gears? Plan on changing them?
80/TA/LT1 is offline  
Old 10-15-2016, 09:59 PM
  #87  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by 80/TA/LT1 View Post
Outstanding build and results! Are you still running 4:10 gears? Plan on changing them?

No I Rebuilt rear and put in 3.23 gears. Work pretty well.
gsxrred1000 is offline  
Old 10-15-2016, 11:25 PM
  #88  
11 Second Club
iTrader: (2)
 
Join Date: May 2011
Posts: 413
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by gsxrred1000 View Post
no i rebuilt rear and put in 3.23 gears. Work pretty well.
yeah they do :d, thx for the reply, 28 in tire i assume? What rpm through the traps?
80/TA/LT1 is offline  
Old 10-16-2016, 03:48 PM
  #89  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by 80/TA/LT1 View Post
yeah they do :d, thx for the reply, 28 in tire i assume? What rpm through the traps?
Yes 275 tire and hit 6400 at stripe. I short shifted 1st to 2nd at like 6100 and 2nd to 3rd was 6300 I. Believe. Normally I shift at 6500. So going threw the traps at 6400 is pretty good.
gsxrred1000 is offline  
Old 10-17-2016, 07:49 AM
  #90  
9 Second Club
iTrader: (18)
 
RedRocketZ28's Avatar
 
Join Date: Jan 2005
Location: Madrid, IA
Posts: 2,065
Likes: 0
Received 0 Likes on 0 Posts
Default

Did you use the Gen 3 crank with the Gen 4 rods? I have a set of Gen 4 rods and pistons in my garage and I am debating on throwing them in my Gen 3 LQ4 this winter or getting crazy and putting forged stuff in it. Just wondering because it looks to be running hard. Nice build and congrats on your most recent pass.

Last edited by RedRocketZ28; 10-17-2016 at 12:14 PM.
RedRocketZ28 is offline  
Old 10-17-2016, 12:02 PM
  #91  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by RedRocketZ28 View Post
Did you use the Gen 3 crank with the Gen 4 rods? I have a set of Gen 4 rods and pistons in my garage and I am debating on throwing them in my Gen 3 LQ4 this winter or getting crazy and putting forged stuff in it. Just wondering because it looks to be running hard. Nice build and congrats on the your most recent pass.

Yes gen 4 rods on gen 3 crank. Did have it balanced tho. Was 50g different from gen 3 rods and dished Pistons to gen 4 rods and flat tops. Think is was worth 220 for peace of mind. They added some weight to crank.
gsxrred1000 is offline  
Old 10-17-2016, 12:15 PM
  #92  
9 Second Club
iTrader: (18)
 
RedRocketZ28's Avatar
 
Join Date: Jan 2005
Location: Madrid, IA
Posts: 2,065
Likes: 0
Received 0 Likes on 0 Posts
Default

Right on. Thanks for the info.
RedRocketZ28 is offline  
Old 05-07-2019, 03:32 PM
  #93  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default Finally hit my other goal in this build !

As u can read on the first page of this thread my end goal was to run 9ís and hit 800whp. 9ís was the easy part and Iíve been chipping away at the hp level for a while now. My first time on th dyno in put down 556hp blowing threw the converter. So after a converter change and turning it up a little bit I hit 656hp, than I upgraded the internals to gen 4 rods and turned it up a little more and went my 9.4 pass and went to dyno after that track outing and power was right at 680 on that pass. I ended up squeaking out another 20 hp with some tuning adjustments to get me to 700hp. I upgraded turbo and went on to keep chipping away at hp level and ran a 9.3 at 147. Back to the dyno I went and hit 760 hp and finally upgraded my 8.5 10 bolt rear that was self destructing over the last few years of abuse to a quick performance 9Ē. Figuring this would be a big power robber I didnít have high hopes for the next dyno outing. I upgraded my maxed out Siemens 80ís to the sep 1500ís for added insurance and to be able to go higher in boost if needed to hit my goal. I spent hours on the street tuning the new injectors so I wouldnít have to spend tons of pulls on the dyno. So again I went to the dyno and 1 st pull on low boost it broke up at 6k rpm I had just recently changed plugs so I was convinced it was not that but with more boost on next dyno pull it was worse. So we went right after plugs and wires and plugs looked rich and afr was reading 12.7. Didnít make sense. Replaced all the plugs and wires looked good. Next pull same thing. I had a gut feeling that my 02 sensor was not reading correctly so we replaced that and next pull it read super fat off the wideband 10:1 afr. That was the culprit so now we had to retune the whole map top to bottom. Not what I had planned for on the dyno. After about 25 more pulls and the tune squared away we ended up hitting 780on pump gas and meth at 22psi, I swapped over to c16 due to pushing the limits and abusing it for 25 previous pulls. We added timing for the c16 and it wasnít picking up much of pump/meth. So we upped the boost to 24psi and hit 799hp. Iím like turn that **** higher Iím so close. So we upped the duty cycle on the boost controller and it only made 1psi more. I was out of wastegate spring but did get rewarded with 807whp. I hit my goal and now changed my 9 sec. goal to 8 sec this year. Thanks to Matt happel for helping make this happen.

gsxrred1000 is offline  
Old 05-14-2019, 08:45 PM
  #94  
TECH Enthusiast
 
Join Date: Sep 2013
Location: Mechanicsburg, PA
Posts: 582
Likes: 0
Received 0 Likes on 0 Posts
Default

Congrats on sticking with it and achieving your goals! Good luck on that 8!
Bad Apache is offline  
Old 05-15-2019, 10:19 AM
  #95  
Staging Lane
 
Join Date: Dec 2017
Posts: 76
Received 0 Likes on 0 Posts
Default

What turbo did you upgrade to? Power output seems a little low for that amount of boost. I'm no expert, though.
jayyyw is offline  
Old 05-15-2019, 04:21 PM
  #96  
TECH Apprentice
 
Join Date: Dec 2018
Location: MIAMI
Posts: 366
Received 4 Likes on 4 Posts
Default

congrats, what do you think the car weights? im praying i run a 9.99 even at that
panda240ss is offline  
Old 05-17-2019, 10:32 PM
  #97  
9 Second Club
Thread Starter
iTrader: (3)
 
Join Date: Jul 2013
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by panda240ss View Post
congrats, what do you think the car weights? im praying i run a 9.99 even at that
Weighs 3550 with me in it.
gsxrred1000 is offline  
 


Thread Tools
Search this Thread
Quick Reply: (Burnout vid )69 Camaro SS Turbo 5.3l/lil john stage 3 cam/th400/s476r DYNO RESULTS


About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: