Notices
PCM Diagnostics & Tuning HP Tuners | Diablo | Pantera EFI

Have to let idle for 2 mins or hangs rpm

 
Old 08-09-2016, 08:00 AM
  #1  
12 Second Club
Thread Starter
 
Rok_Star_Bars's Avatar
 
Join Date: Nov 2013
Location: 45 Mins Below ATL, GA
Posts: 63
Default Have to let idle for 2 mins or hangs rpm

Looking for some ideas here. Did a Head and cam swap on my 2002 Trans Am LS1. I'm data logging my test drives to my tuner. But we seem to have a little issue with Idle. Everything else is perfect.

EVERYTIME I start the car I have to let it idle for 2 mins, or I will get the cruise control effect and hanging rpm. And once it starts to hang it WILL NOT go away unless, I cut the car off, restart the engine, and let it idle for the 2 mins.

Part 2 to the problem is if I start it with A/C off, I can not turn A/C on. Because it will do the same thing and will not go away, without a restart, or turn A/C back off. I either have to start it with A/C on or off. I cant switch once I start the car or it will start to hang.

Tuner is pretty dang good and is trying hard (several adjustment too idle stuff but luck), but he is not local, so its kinda a disconnect, if there is a hard fault. Because I think we are both wondering, if there is more too it then the tune now.

I have changed out my TB with a spare, Clean the TB and IAC good, I swap IAC with a spare I had. Same TPS.

Random codes, start up with A/C on I have got TCS Off 5 times, ABS 1, and MAP DTC 3 times.

It has thrown a TPS and IAC DTC twice. But haven't lately.

Mod list: LS1, CNC Ported 799, .625 lift/109 LCA, #42 injectors, LS6 intake, LT, ORY, Dual Dual
Rok_Star_Bars is offline  
Old 08-09-2016, 08:57 AM
  #2  
12 Second Club
Thread Starter
 
Rok_Star_Bars's Avatar
 
Join Date: Nov 2013
Location: 45 Mins Below ATL, GA
Posts: 63
Default

Also saying all that. I have about 500 miles on this setup and ALOT of start ups. So the codes being thrown isn't that often
Rok_Star_Bars is offline  
Old 08-09-2016, 07:01 PM
  #3  
Moderator
iTrader: (11)
 
jimmyblue's Avatar
 
Join Date: Mar 2002
Location: East Central Florida
Posts: 12,614
Default

Often "cruise control effect" is from a vacuum leak that
IAC_counts=0 can't do anything about. That's question
#1 - when "hung" is IAC trying to go to zero (and is idle
closed loop RPM control active, or defeated, is Q#2).

What happens at t=2 minutes? AIR pump shutoff? Just
happen to get back to closed loop idle RPM at that time?

Weird A/C behavior (esp. refusing to engage at idle)
may be an artifact of the tune. Turning off "stall saver
strategies" could show whether this is that kind of mental
problem (fixing it may want more idle tuning for stability).
A/C does bump desired airflow and maybe somewhere
along the line, something kooky bistable has gotten into
that mess (a long chain from air temp to bump torque to
desired air mass to desired airflow, there's some tables
that might be bad news if munged).

Might put an eye on A/C system pressures and see if
you have low side underpressure or high side over-
pressure that's messing with you. Wouls not expect this
to have a fixed time-signature but maybe it's just a
coincidence that behaves roughly the same way when
it happens.
jimmyblue is offline  
 


Thread Tools
Search this Thread
Quick Reply: Have to let idle for 2 mins or hangs rpm


About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: