blinker not blinking - LS1TECH - Camaro and Firebird Forum Discussion

Notices
General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

blinker not blinking

Reply

Old 11-02-2011, 01:28 PM
  #1  
Teching In
Thread Starter
 
trans665's Avatar
 
Join Date: Jan 2011
Location: corpus christi
Posts: 47
Default blinker not blinking

i got a 1999 z28, the right hand blinker is staying lit, not blinking when i hit the swicth..both lights front and back are on..
i need to go for my inspection and want to fix this, has anyone had this trob before??
trans665 is offline  
Reply With Quote
Old 11-02-2011, 02:05 PM
  #2  
11 Second Club
iTrader: (5)
 
DannoWS6's Avatar
 
Join Date: Apr 2004
Location: Central MA
Posts: 1,473
Default

Sounds like low blinker fluid to me.

Or less likely, a blown bulb.
DannoWS6 is offline  
Reply With Quote
Old 11-02-2011, 02:07 PM
  #3  
On The Tree
iTrader: (3)
 
Blasko's Avatar
 
Join Date: Feb 2011
Location: South FL
Posts: 145
Default

Under the dash there is a blinker module. Its a small grey cylinder.
Probably just need one of those.
Autozone/Junkyards will have plenty.

Looks like this


Blasko is offline  
Reply With Quote
Old 11-02-2011, 02:13 PM
  #4  
11 Second Club
iTrader: (5)
 
DannoWS6's Avatar
 
Join Date: Apr 2004
Location: Central MA
Posts: 1,473
Default

DannoWS6 is offline  
Reply With Quote
Old 11-02-2011, 02:21 PM
  #5  
Teching In
Thread Starter
 
trans665's Avatar
 
Join Date: Jan 2011
Location: corpus christi
Posts: 47
Default

thanks alot guys..
trans665 is offline  
Reply With Quote
Old 11-02-2011, 10:43 PM
  #6  
On The Tree
iTrader: (2)
 
Join Date: Nov 2010
Location: Jacksonville, NC
Posts: 156
Default

Originally Posted by BlaskO View Post
Under the dash there is a blinker module. Its a small grey cylinder.
Probably just need one of those.
Autozone/Junkyards will have plenty.
Its prob the bulb. If the module is bad wont both blinkers not work?
jarheadtex is offline  
Reply With Quote
Old 11-03-2011, 12:08 AM
  #7  
The Scammer Hammer
iTrader: (49)
 
dr_whigham's Avatar
 
Join Date: Apr 2009
Location: Lafayette, LA
Posts: 6,406
Default

Those bulbs are DUAL filament.

Just get a new 3457 or 3157. I bet it works..... My TA used to do this when I'd drive for a while in the rain.
dr_whigham is offline  
Reply With Quote
Old 11-03-2011, 06:40 AM
  #8  
11 Second Club
iTrader: (5)
 
DannoWS6's Avatar
 
Join Date: Apr 2004
Location: Central MA
Posts: 1,473
Default

Originally Posted by jarheadtex View Post
Its prob the bulb. If the module is bad wont both blinkers not work?
You actually have 2 flasher relays under the dash. The one on the left is for the hazards and the one on the right the normal blinker. If you hit the hazards and all the light work fine, then its probably the other flasher. Otherwise its a bulb or maybe even a bad bulb socket.
DannoWS6 is offline  
Reply With Quote
Old 11-03-2011, 08:22 AM
  #9  
Save the manuals!
iTrader: (5)
 
wssix99's Avatar
 
Join Date: Dec 2007
Location: Chicago, IL
Posts: 10,561
Default

Originally Posted by jarheadtex View Post
Its prob the bulb. If the module is bad wont both blinkers not work?
Sometimes, yes, and sometimes not. The electrical resistance is slightly different on each side of the car, which can cause a boarderline thermal flasher to behave differently on each side.
wssix99 is offline  
Reply With Quote
Old 11-03-2011, 06:50 PM
  #10  
Teching In
Thread Starter
 
trans665's Avatar
 
Join Date: Jan 2011
Location: corpus christi
Posts: 47
Default

i just put the hazards, on all lights blink. when i go for a left hand turn they bink. but when i go for the right hand the lights just stay lit.
so i now know its not the bulbs, you think that relay thingy is the prob??
trans665 is offline  
Reply With Quote
Old 11-03-2011, 06:52 PM
  #11  
The Scammer Hammer
iTrader: (49)
 
dr_whigham's Avatar
 
Join Date: Apr 2009
Location: Lafayette, LA
Posts: 6,406
Default

Dude, the same thing would happen with my Trans am. All the lights WILL blink when you put on the hazards. The turn signal filiment, not the steady on, has went out on the right side.

Replace the bulb
dr_whigham is offline  
Reply With Quote
Old 11-03-2011, 07:01 PM
  #12  
Teching In
Thread Starter
 
trans665's Avatar
 
Join Date: Jan 2011
Location: corpus christi
Posts: 47
Default

i will try that in the morning, thanks.
trans665 is offline  
Reply With Quote
Old 11-03-2011, 11:13 PM
  #13  
On The Tree
 
z28boycali's Avatar
 
Join Date: Mar 2010
Location: BAY AREA
Posts: 153
Default

There's 3 things that can be it.
-bulbs
-blinker module(located under steering wheel)
-daylight running module(black box behind stereo)
z28boycali is offline  
Reply With Quote
Old 11-04-2011, 12:55 PM
  #14  
Teching In
Thread Starter
 
trans665's Avatar
 
Join Date: Jan 2011
Location: corpus christi
Posts: 47
Default

the new buld fixed the prob, thanks......last night was the frist time i drove the car in the dark, my highlight swicth dont click,and i dont dont get no high lights?? prob after prob, now i got to fix that before inspection
trans665 is offline  
Reply With Quote
Old 11-04-2011, 05:20 PM
  #15  
Save the manuals!
iTrader: (5)
 
wssix99's Avatar
 
Join Date: Dec 2007
Location: Chicago, IL
Posts: 10,561
Default

Originally Posted by trans665 View Post
the new buld fixed the prob, thanks......last night was the frist time i drove the car in the dark, my highlight swicth dont click,and i dont dont get no high lights?? prob after prob, now i got to fix that before inspection
https://ls1tech.com/forums/general-m...er-switch.html

or... those bulbs could be burned out
wssix99 is offline  
Reply With Quote
Old 11-04-2011, 06:51 PM
  #16  
Teching In
Thread Starter
 
trans665's Avatar
 
Join Date: Jan 2011
Location: corpus christi
Posts: 47
Default

thanks for the info!!!! i will look at that when i get my car into the garage tonight.
trans665 is offline  
Reply With Quote
Old 11-04-2011, 08:03 PM
  #17  
The Scammer Hammer
iTrader: (49)
 
dr_whigham's Avatar
 
Join Date: Apr 2009
Location: Lafayette, LA
Posts: 6,406
Default

Glad I could help a little... LOL

Always seems like you get one hing fixed, just for another issue to rear it's ugly head.
dr_whigham is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: blinker not blinking


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: