Notices
Generation IV Internal Engine 2005-2014 LS2 | LS3 | LS7 | L92 | LS9

Ls3 NA Build For My Focus

 
Old 03-22-2018, 08:28 AM
  #61  
10 Second Club
 
big hammer's Avatar
 
Join Date: May 2009
Location: over dere
Posts: 3,136
Default

Ls3 engines are the cats ***
big hammer is offline  
Old 03-22-2018, 07:58 PM
  #62  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

Bob with Cam Motion had been a ton of help. He is grinding be a new solid roller cam for the car. I cant wait to get this all back together. Im hoping I make decent gains. Also gonna be raising compression a little bit by decking the heads.
topspeed1 is offline  
Old 03-22-2018, 08:32 PM
  #63  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,480
Default

Originally Posted by topspeed1 View Post
Bob with Cam Motion had been a ton of help. He is grinding be a new solid roller cam for the car. I cant wait to get this all back together. Im hoping I make decent gains. Also gonna be raising compression a little bit by decking the heads.
If you were straight up with him on your needs and goals on your engine, you WILL see solid gains with the new cam. I have NEVER heard a negative remark on these guys. They are GOOD!
G Atsma is online now  
Old 03-22-2018, 09:36 PM
  #64  
10 Second Club
 
big hammer's Avatar
 
Join Date: May 2009
Location: over dere
Posts: 3,136
Default

I love my new LLSR Cam ground by Cam
Motion and specd by Horse **** cams
big hammer is offline  
Old 03-30-2018, 04:37 PM
  #65  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

Got the heads back from machinist today. I checked the cc's of the heads since he had to cut them to repair the damage.

Motor is closer to 14:1 now which is what i was originally shooting for.

Also my Cam Motion llsr cam came in today.

Im still waiting on my shaft mount rockers to come in.

topspeed1 is offline  
Old 04-12-2018, 04:38 PM
  #66  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

Well I cant catch a break.

I got the car on the dyno yesterday and intermittently the car runs like crap. Sounds like an ignition timing problem. Back fires, runs lean, cuts off, wont rev,

I had a check engine for cam position sensor high voltage. I replaced the sensor and had the same problem.

I then installed a new computer today and still have the problem. I have isolated the issue to reflashing the computer. About one out of ten times I reflash the computer it runs great. But then the rest of the time it runs like crap.

Any ideas?

Im Running HP Tuners.

Im about to pull my hair out.
topspeed1 is offline  
Old 04-12-2018, 04:44 PM
  #67  
Launching!
iTrader: (4)
 
Join Date: Oct 2008
Posts: 276
Default

I've had similar issues with HPTuners.

When things get really funky or stop working completely I completely unhook all the connectors from the computer and then plug it back it and re-flash.

Also, try doing a "write entire"
spanks13 is offline  
Old 04-12-2018, 07:31 PM
  #68  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

Originally Posted by spanks13 View Post
I've had similar issues with HPTuners.

When things get really funky or stop working completely I completely unhook all the connectors from the computer and then plug it back it and re-flash.

Also, try doing a "write entire"
Im gonna try that in the morning
topspeed1 is offline  
Old 04-18-2018, 08:04 PM
  #69  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

Well after screwing with the car on the dyno last week and having a couple issues I decided to rip out the stock harness and hp tuners and I ordered a holley efi system. I just dont think the stock stuff is cut out for what im trying to do.

So far the holley seems great. I installed it today and the car fired right up. Hopefully dyno tuning will be as easy.

I ended up getting the dash for it too.

Also after dynoing the car last week i realized I am getting 25 percent slip at 8000rpms. Obvisouly the converter i had wasnt cut out for the job.

I installed a new convertor today.

Also the new cam from cam motion is awesome. The power hasnt peaked at 8000rpms. I cant wait to actually turn it out.





topspeed1 is offline  
Old 12-30-2018, 08:39 AM
  #70  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

I am making a little progress with the new bottom end.

This time a 4 inch stroke. Should be around 13:1 compression.



topspeed1 is offline  
Old 12-31-2018, 09:32 AM
  #71  
Staging Lane
 
Join Date: Dec 2017
Posts: 98
Default

What was the results on the build back in April? I'm on my work computer so the pictures wont load. I'm building a ls3 for my truck but won't turn anywhere near 8K. I'm happy with 7K. Lol
LSleeper1500 is offline  
Old 01-14-2019, 12:44 PM
  #72  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

Originally Posted by LSleeper1500 View Post
What was the results on the build back in April? I'm on my work computer so the pictures wont load. I'm building a ls3 for my truck but won't turn anywhere near 8K. I'm happy with 7K. Lol
Yeah back in april i spun a rod bearing so i decided to stroke the motor to 4 inches and spin less rpms
topspeed1 is offline  
Old 01-14-2019, 12:47 PM
  #73  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

So i am waiting on a couple parts to finish engine assembly and i was thinking about port matching the heads and intake manifold.

What are your thoughts? I know every little bit helps but not sure if time would be better spent else where.





heads are tfs 255s and the intake is a sheet metal 104mm
topspeed1 is offline  
Old 01-19-2019, 02:03 PM
  #74  
8 Second Club
iTrader: (2)
 
RonSSNova's Avatar
 
Join Date: Aug 2011
Location: Portland, OR
Posts: 3,000
Default

Does that gasket exactly match the port in the intake manifold?
When all is said and done, the manifold should match the head.
Manifold a smidge smaller is fine. Manifold bigger, match the intake port in the head to the manifold.

Ron
RonSSNova is offline  
Old 01-22-2019, 07:45 PM
  #75  
Launching!
Thread Starter
iTrader: (2)
 
topspeed1's Avatar
 
Join Date: Apr 2017
Location: Washington NC
Posts: 209
Default

here is a burn out video from my ls3 last year.

topspeed1 is offline  
 


Thread Tools
Search this Thread

About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: